This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BQ4050: Failure of Discharge FET once battery fully discharged

Part Number: BQ4050
Other Parts Discussed in Thread: CSD17570Q5B, BQ24600


Configuration is as follows:

1. Using 4S1P lipo cells 8000mah

2. Load used while discharging of 7A

3. CSD17570Q5B (30V, 100A) as CHG and DSG FET

After charging the battery using BQ24600 as charger, I discharged the battery using 7A load.

Under voltage threshold was set at 3300mv per cell, So once it reached below threshold DSG FET is triggered OFF and SafetyStatus[CUV=1.

I removed the load but output at pack voltage is showing almost same as input voltage and when I again enabled DSG FET it shows twice of input voltage at output.

This happened twice. Can you help in finding the issue as when I partially discharge then this issue does not come.

I have attached the image of protection FETs.

  • Hi,

    Can you upload a log showing this issue and the .gg.


  • Hi Amit,

    Your log does not show any issues with the pack voltage.



  • Hey Nick,

    Sorry for my wrong observation. It does not happen just after removing the load. The log was only generated until DSG FET was disabled. So nothing was logged after that.

    One more time I checked after replacing my faulty MOSFET. I tried multiple times discharging and then disabling DSG FET.

    But  no issue came , it was working fine. Finally during the night when the battery was half discharged, i disabled DSG FET but physically I kept the load connected and went for sleep. In the morning when I woke up I found my Battery fully discharged to 0V as my DSG FET was burnt and D & S was sorted. Unfortunately nothing was logged as it was not my intention to check anything. I thought I would check in the morning but it happened again. Earlier also I think similar incident happened but still I can not say it clearly and also I don't have any logs to check.

    So next time I will try to take logs properly and sacrifice one more mosfet but it might take some time as I ran out of FETs.

    Meanwhile I just wanted to know the possible reasons if you can tell like

    1. is my schematic or selection of FET(CSD17570Q5BT) correct?

    2. What could be the possible reason for this behaviour?

    3. Further going I am designing this PCB for handling continuous discharge current of 20A and peak 30A current, so what should I keep in mind?

    Any help would be great going ahead? Since this is my first time handling these type of ICs, I might be doing some basic mistakes which I am not aware of. So please bear with me.

    Please find the clubbed schematic here: schematic

  • Hi Amit,

    I have reviewed the FET section everything looks ok. Without a log it is hard to say what caused the FET to die.

    Most chargers will output a voltage even when they are not charging which is what you could be seeing. Did you still have the charger connected when you disconnected the load?

    You might also check if any of the PFs have been set. 

    Best regards,


  • No, charger was not connected. Will do proper logging once I get my new FETs.

    In case you can look upon my PCB. PFA

  • Hi Nick,

    I did get my MOSFETS and was testing my circuit, I did not get any issue till now but two things  I am doing differently now:

    1. Earlier I was using DSG_FET_TOGGLE separately and CHG_FET_TOGGLE separately to toggle while discharging and charging but now I am using only FET_EN.

    I am not sure  whether that caused the issue. I have not tried that again but I will do that once I get other things working properly. One of my observation is that when only DSG FET is active, the voltage at pack is slightly lower than when both FETs are active.

    2. I have removed the MOSFET which protects DSG FET from reverse polarity as in my case gate of the MOSFET was connected to ic ground whereas in datasheet that is connected to CHG GND.

    I don't think these would have caused the issue but I just wanted you to know in case these could cause the problem, please let me know

  • Hi Amit,

    If you use FET_TOGGLE commands, gauge will not be able to control FETs normally, they are for test purposes only, FET-EN should be used in order to turn FETs on and off when conditions are met.

    Best Regards,