This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TLC5947: The Outputs are always 0

Prodigy 80 points

Replies: 4

Views: 96

Part Number: TLC5947

Hi, I am using TLC5947 to drive multiple LEDs in my project. I have been playing with it for a while, but the channel's output is kept 0. I am not sure where is my problem, any help is appreciated. The BLANK pin is connected to GND, Vcc is connected to 3.3v source, and other operations have been shown below. I tried to write GS[18-20] (Chanel18-20) to 0xFFF.  

  • From the figure, it seems that it meets the following requirements:

    You can try to send all channels with 0xFFF to see the effect.

    We also suggest you can control your BLANK pin since it can reset the GS counter.

    Please also refer to our sample code:

    Vers2_TLC5947_MSP_EXP432P401R_nortos_ccs.zip

    Thanks and best regards,

    Kenneth

  • In reply to Kenneth Du:

    Hi Kenneth, Thank you very much for your reply. It works after I change LED from common cathode to common anode. Is it because of my internal reference resistor is too large? I want my design works on common cathode LED.

    Thank you very much,

  • In reply to Pengcheng Liu:

    Hi, Pengchen,

         The TLC5947 is constant-current sink output. So it should be used in common anode.

    Thanks and best regards,
     Charles Chen
     Applications Engineer | LED Drivers


    Check out these helpful resources

    LED Drivers ICs | LED Drivers Reference designs | LED Driver Basics Training series 

  • In reply to Charles-Chen:

    Hi Charles,

    thank you very much for your reminder, it helps.

    Pengcheng.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.