This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

LMR16030: Voltage drop issue when current = 2.6A

Intellectual 930 points

Replies: 5

Views: 122

Part Number: LMR16030

Hi team,

My customer just send me a question about LMR16030:

The regulated output voltage is 3.9V. When the current is added to 2.6A, the output voltage will drop to 3.6V. Sorry for can't post the schematic, but it's basically the same with the reference design. The test and waveform figure is attached below.

Can you analyze this issue and give me several possible answers?

Thank you.

Gary

  • Taoran Jiang,

    If the output ramps down while output current ramps up, you may be hitting current limit. Check the inductor ripple and check that the inductor is not saturating.

    If the output voltage jumps to 3.6V when you hit a certain output current threshold, check the SW node to ensure the SW waveform is as expected.

    Check the FB pin voltage. Is it 0.75V as expected? If so, the issue may be board parasitics.

    -Sam

    ---------------------------- Resources ----------------------------

    Product search: TI's Buck Converters, Controllers, and Modules.

    Support: Tech Docs, Articles, Design ToolsE2E

  • In reply to Samuel Jaffe:

    Hi Sam,

    I don't have LMR16030 EVM in hand, so I use a LMR14030 EVM to do the overcurrent experiment. When the inductor ripple reaches the overcurrent threshold, the output voltage will immediately drop to below 1V. Before the current hits the threshold the output voltage is barely flat. So this may not be the cause.

    Now I get to know that when the LMR16030 output at 3.6V/2.6V, the inductor and the chip both are heated badly. So for now I suppose the inductor is saturated and the temp rise in the LMR16030 may be derated and causes this voltage drop.

    Is my assumption reasonable? My engineer will tell me the result when he changes the inductor saturation rating and test it again.

    Thank you for your help.

    Gary

  • In reply to Taoran Jiang:

    Gary,

    Yes, a saturated inductor can cause the output to regulate poorly. Let me know the result of the test.

    -Sam

    ---------------------------- Resources ----------------------------

    Product search: TI's Buck Converters, Controllers, and Modules.

    Support: Tech Docs, Articles, Design ToolsE2E

  • In reply to Samuel Jaffe:

    Sam,

    The engineer found he measured the voltage at the load side, not directly at the pins. So the voltage drop actually is because of the line loss. Now there is no problem any more.

    Thank you for your answer, we can close this case.

    Gary

  • In reply to Taoran Jiang:

    Gary,

    Thanks for following up. 

    -Sam

    ---------------------------- Resources ----------------------------

    Product search: TI's Buck Converters, Controllers, and Modules.

    Support: Tech Docs, Articles, Design ToolsE2E

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.