TMDS243GPEVM: TMDS243GPEVM

Part Number: TMDS243GPEVM

Got the eval from TI

Powered up using the recommended procedure.

All LED are ON but LD2  for VDD_Core.

is anything wrong, is a bad board or something else is required to turn the power on?

Thanks,

Dorel

  • Hi Dorel,

    LD2 should be illuminated, so something is wrong.

    Please see AM64x/AM243x GP EVM User's Guide (spruix0c.pdf), "Power-On/Off Procedures" for the power-up procedure. The Power IC board can be damaged if this procedure isn't followed exactly. However, in the case I'd expect to see more LEDs than LD2 not illuminated.

    If the board operates normally otherwise, it might be OK to continue using it.

    This is a link to the RMA form in case you need to return the board: https://www.mistralsolutions.com/product-engineering-services/rma-form/

    Regards,
    Frank

  • all other LEDs are working fine but LD2.

    I cannot connect to the micro

  • Hi Dorel,

    Can you please outline how to tried connecting to the board? Which instructions did you follow?

    I suggest you have the board replaced if you've followed all instructions for power-up, setting up a target configuration, and connecting to the board, but still LD2 isn't illuminated and you're unable to connect.

    Regards,
    Frank

  • Same with me here - fresh TMDS243GPEVM but LD2 is off. All other LEDs are on. The board seems to run, at least partially - some simple examples work (e..g i2c_led_blink, hello_world. But not everything - complex examples cannot load (eip, lwip, ethercat), out-of-the-box demo also hangs on "connecting target 2 of 2", DDR initialization GEL script never succeeds (in CCS 10.4).

    I am pretty sure that I've treated the board right - we know about power jack troubles from other Sitara boards/IDKs, so we only plug from the mains socket.

    I've just measured the VDD CORE at the test points TP55 and TP54 - it reads 0.8469V.

  • I tried out of box experience. XDS interface works, but not able to load to firmware into the target

    Before I get the hands into the firmware design and evaluation I always use the default option to get the board working as is coming from your manufacturing

    Thanks,

    Dorel

  • On my setup, XDS is able to connect and load the code on the board, and at the end, it needs to establish a connection to receive measurement data from the R5 cores - at this point, it stays endlessly on connecting to target 2 of 2.

    I also tried the CCS Cloud IDE (the newer beta) and I could say that it works on par with the desktop CCS - all the examples that I could run on the desktop CCS (under Win10) are running in the cloud workspace using TI Cloud bridge Chrome extension. Still, more complex examples (e.g. EtherCAT and EIP from industrial protocols) fail to load - maybe those use more than one core. But the simple one (i2c led, hello, OSPI benchmarks) does run correctly.

    The LD2 is not directly passively driven by the VDD core supply - it is a GPIO controlled through a small MOSFET - so it could be a minor SW issue. My guess is that your board is fine (not damaged by power issue) and you need to fix something in your development setup.

    You can PM me to get direct contact - I am just starting with this board (and the AM64x-SK) but I have some experience with the TI ecosystem.

    For generic debugging, you should follow strictly the EVM setup steps in the getting started MCU+SDK documentation - it loads the appropriate SBL bootloader.

  • Hi,

    On TMDS243GPEVM, LD2 is not applicable, so this led status can be ignored. This is because both VDD_CORE and VDDAR_CORE are rails are at 0.85V and the resistor R57 is not populated in the below circuit for generating the VDD_0V85_PG that drives the LD2.

    This does not seem to be hardware issue since the voltage measured on VDD_CORE is correct.

    Thank you,

    Anita

  • Hi All,

    if is not a hardware issue, what is it please?

    I cannot upload any firmware, the board is useless.

    If I return the board and get another ones with the same issue? is it anything wrong with the firmware in XDS?

    Thanks,

    Dorel

  • Dorel,

    I received confirmation that your replacement board is working as expected so I will close this thread. If you are still having issues, please feel free to post a reply to this thread or create a new one if this one has locked due to timeout. 

    Regards,
    Sahin