The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMS320C6745: Using ROV in code composer studio V11 for C6745

Genius 3955 points
Part Number: TMS320C6745

Hi experts,

My customer is migrating from CCSv5 to CCSv11 and is having problems when using ROV (Runtime Object View).

Can the ROV of TMS320C6745 be used with CCSv11?

The details of the problem are as follows

  • ROV Classic: The status of events, etc. can be checked, but the status of tasks, etc. is not displayed.
  • ROV: Error "ROV_connect failed to start agent: MissingExtesion: MISSING_EXTETSION" is displayed and does not work properly.


I would appreciate it if you could tell me what I need to check about the settings and if there are any documents I can refer to.

Best regards,
O.H

  • Hello,

    I can reproduce the issue with ROV Classic with my CCS 11.1 installation. The same program works fine with an older CCS version (8.3.1) hence it appears there is some regression with ROV Classic in current CCS versions. Note that ROV Classic is no longer supported so I don't think we can do much about it. Hence I would like to focus on the issue with the new ROV. I am unable to reproduce the "MissingExtension" error in my environment. I used the same SYS/BIOS and XDCtools version, though I used a different 674x target (C6748). It worked fine. I will need to escalate the curstomer issue to engeineering for further suggestions. I will pass on any updates as I receive them.

    Thanks

    ki

  • I will need to escalate the curstomer issue to engeineering for further suggestions. I will pass on any updates as I receive them.

    Engineering feels the issue is related to the TI Cloud Agent which ROV has a dependency on. Cloud Agent is actually used by ROV in CCS desktop.

    Can the customer enable cloud agent logging in CCS desktop and reproduce the issue? Then provide the the log for analysis (it can be attached to this thread)

    https://software-dl.ti.com/ccs/esd/documents/ti_cloud_agent.html#logging

    Note that since CCS Desktop is used, the bat file to be modified is the one inside the CCS installation directory (see the last "NOTE" on the page above).

    Thanks

    ki

  • Also please request to the customer for their Eclipse error log.

    It should be in <WORKSPACE FOLDER>\.metadata\.log

  • Hi Ki,

    Thank you for your reply.

    Engineering feels the issue is related to the TI Cloud Agent which ROV has a dependency on. Cloud Agent is actually used by ROV in CCS desktop.

    Can the customer enable cloud agent logging in CCS desktop and reproduce the issue? Then provide the the log for analysis (it can be attached to this thread)

    https://software-dl.ti.com/ccs/esd/documents/ti_cloud_agent.html#logging

    Note that since CCS Desktop is used, the bat file to be modified is the one inside the CCS installation directory (see the last "NOTE" on the page above).

    I had a customer try the above, but another error occurred and the ROV could not be used. Also, the logs are not being output to c:\temp. I will share the rewritten bat file and error screen.

    ticloudagent.bat.txt
    @echo off
    
    set PATH=%~dp0\util;%PATH%
    set TI_DS_ENABLE_LOGGING=1
    set TI_DS_LOGGING_OUTPUT=c:/temp/my.log
    echo ---ARGS--- %1 %2 %3 > c:/temp/my.log
    
    if "%~1"=="not_chrome" goto NOT_CHROME else goto CHROME
    
    :CHROME
    rem echo ---CHROME--- >> c:/temp/my.log
    "%~dp0/node.exe" "%~dp0/src/main_chrome.js" %*
    goto END
    
    :NOT_CHROME
    rem echo ---NOT_CHROME--- >> c:/temp/my.log
    "%~dp0/node.exe" "%~dp0/src/main.js" %*
    
    :END
    
    

    Also please request to the customer for their Eclipse error log.

    It should be in <WORKSPACE FOLDER>\.metadata\.log

    Can I share the Eclipse error log in private chat as it contains customer information? I have sent you a friend request and would appreciate your permission.

    Best regards,
    O.H

  • Thank you. I have received your private message. Let us continue further discussion there