This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMS320C6416T: Debug error

Part Number: TMS320C6416T

Hello all,

I have dev board with TMS320C6416t, emulator XDS100 v3,  jtag connection test is fine, but when I run the debugger I get the error:

Error connecting to the target: (Error -1004 @ 0x0) Device is not responding to the request. Reset the device, and retry the operation. If error persists, confirm configuration, power-cycle the board, and/or try more reliable JTAG settings (e.g. lower TCLK). (Emulation package

Here is the schematic jtag which i used

I followed this pattern

I use CCS  Version:

  • I'm only able to answer hardware related questions, so may need to re-assign this thread to someone more familiar with configuring the debugger and using Code Composer Studio (CCS).

    I see a potential problem with your JTAG connectivity. It appears you did not insert 22 ohm series termination resistors as shown in the recommended schematic diagram. Series termination resistors will reduce signal distortion on these clock signals which occurs when branching the JTAG clock signal coming from the debugger into two separate signal paths, TCK and RTCK. Inserting these series termination resistors will improve impedance matching and reduce reflections. Without these resistors, the clock signals may have enough distortion on them to cause the clock input buffers to produce glitches on internal clocks.

    Can you provide more information about what is meant when saying "jtag connection test is fine, but when I run the debugger I get the error". As mentioned above, I'm not familiar with details of using the debugger. How do you perform jtag connection test? Is this test performed using the same hardware and software that is being used when you get the error? If so, I will need to re-assign the thread to the someone on the CCS team.


  • Thanks for the answer

    Yes, jtag was checked using "Test connection" in the "Targer Configurations" setup window in the CCS program
    As for the resistor, I'll try to connect with it tomorrow, but I think it won't help, because I even tested at a frequency of 10kHz, critical reflections should not occur at this frequency, etc.

  • Reducing the JTAG clock frequency will provide time for data signals to settle before being latched on the rising edge of clock. However, my signal integrity concern is not frequency dependent. Reflections on a clock signal can cause non-monotonic transitions that gets applied to the input buffer. This can cause the input buffer to toggle its output multiple times during each non-monotonic transition if the signal changes direction near the input buffer's switching threshold. When this occurs, the input buffer will produce clock glitches inside the respective device and over-clock synchronous logic circuits, which may perform unpredictable operations when over-clocked.

    There is a good chance your problem is not related to my concern since the test connection test works as expected. However, you should always be careful when using a clock source with multiple loads.

    I will go ahead and assign your post to someone on our CCS team to see if they have any other suggestions based on the error code you are receiving


  • Hello,

    Error connecting to the target: (Error -1004 @ 0x0) Device is not responding to the request.

    Basically, the device is not responding to debug requests from the debugger, appearing hung.

    When does this error occur? When you first try to connect to the target? Or are you able to initially connect but then run into issues when trying to run your program?

    Please see the below link for more details on the error: