This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

AM3356: Inquiry about yocto build error

Part Number: AM3356

Hi Experts,

Our customer is developing the next generation system board with AM3356, customer encountered build error suddenly. Customer is trying to find the root cause, but, they are not able to find it at this time. Customer is evaluating following environments. It seems any combination results in an build error.

  • SDK: or 07.03.00
  • Host OS: Ubuntu 18.04 or 20.04
  • python version: 3.6.1 or 3.8.10

When customer tried to do building u-boot and linux kernel, it seems the following error occurs in the phase called do_package after compiling.

cp: cannot stat '/home/xxxx/yyyy/tisdk/build/arago-tmp-external-arm-glibc/work/am335x_evm-linux-gnueabi/linux-ti-staging/5.4.106+gitAUTOINC+023faefa70-r22a.arago5.jrn260k3/srcipk-staging/board-support/linux-5.4.106+gitAUTOINC+023faefa70-g/.': No such file or directory

This is an example of using a linux kernel, but u-boot is exactly the same result. I attached the entire log ( log.do_package.23534 )


This package is created by run.populate_srcipk_package.23534 script dynamically. It seems this script is in the following directory.


it seems this script tried to copy " srcipk-staging/board-support/linux-5.4.106+gitAUTOINC+023faefa70-g" into " packages-split/linux-ti-staging-src/board-support/linux-5.4.106+gitAUTOINC+023faefa70-g" in same directory. However, The directory that actually exists is "linux-5.4.106 + gitAUTOINC + 023faefa70-g023faefa70".

Customer confirmed above directories name as follows.

$ cd ~/jrn260k/tisdk/build/arago-tmp-external-arm-glibc/work/am335x_evm-linux-gnueabi/linux-ti-staging/5.4.106+gitAUTOINC+023faefa70-r22a.arago5.jrn260k3

$ ls srcipk-staging/board-support/


$ ls packages-split/linux-ti-staging-src/board-support/


Customer is considering that it seems SRCIPK_INSTALL_DIR ( in meta-arago/meta-arago-distro/classes/sourceipk.bbclass ) is related to this issue, but, they were not able to find the root cause, so, customer is requesting TI to share experts advice.

Can we have your advice/comments on this issue, please?

Since I got the recipe file, I attached linux-ti-staging_5.4.bbappend, as well.

it may be related to yocto environment, but, it will be really appreciated if your will share expert's advice.

Best regards,


  • Miyazaki-san,

    can you please try updating the local.conf with the suggestions made here and report back if that fixes it.

    This seems to be a recent issue affecting several of our platforms, and I filed an internal bug report for further investigation.

    Regards, Andreas

  • Hello Andreas-san,

    Thank you for your comments on this.

    I shared your comments with csutomer. I'd like to wait for customer's feedback.

    Best regards,


  • Hello Andreas,

    I received feedback from customer. Customer added the following descriptions in tisdk/build/conf/local.conf file, customer checked if error was resolved or not.

     CREATE_SRCIPK_pn-linux-ti-staging  = "0"
     CREATE_SRCIPK_pn-u-boot-ti-staging = "0"

    Regarding SDK v07_03_00, this compile error was resolved. Regarding SDK v06_03_00_106, it seems error still occurs. Therefore, customer tried to do analysis and they fond the difference in tisdk/sources/meta-arago/meta-arago-distro/conf/distro/include/ . after that, even for SDK v06_03_00_106, when customer replaced "=" with "?=" as follows, customer was able to avoid build-error.

    CREATE_SRCIPK_pn-u-boot-ti-staging ?= "1"
    SRCIPK_INSTALL_DIR_pn-u-boot-ti-staging ?= "board-support/u-boot-${PV}${UBOOT_LOCALVERSION}
    SRCIPK_PRESERVE_GIT_pn-u-boot-ti-staging ?= "true"
    CREATE_SRCIPK_pn-linux-ti-staging ?= "1"
    SRCIPK_INSTALL_DIR_pn-linux-ti-staging ?= "board-support/linux-${PV}${KERNEL_LOCALVERSION}"
    SRCIPK_PRESERVE_GIT_pn-linux-ti-staging ?= "true"
    SRCIPK_SHALLOW_CLONE_pn-linux-ti-staging ?= "true"

    Customer investigated the reason why this error occurred, they found it was Git-update. It seems there is Ubuntu version which has issue in GitHub.

      $ apt policy git
       Installed version: 1:2.17.0-1ubuntu1
       Candidate:      1:2.17.1-1ubuntu0.10
       Version Table:
         1:2.17.1-1ubuntu0.10 500  <--- Error occurs
        500 bionic-updates/main amd64 Packages
        500 bionic-security/main amd64 Packages
     *** 1:2.17.0-1ubuntu1 500     <-- No issue
        500 bionic/main amd64 Packages
        100 /var/lib/dpkg/status


      $ apt policy git
       Installed version : 1:2.25.1-1ubuntu3
        Candidate:      1:2.25.1-1ubuntu3.3
       Version Table:
         1:2.25.1-1ubuntu3.3 500  <--- Error occurs
        500 focal-updates/main amd64 Packages
        500 focal-security/main amd64 Packages
     *** 1:2.25.1-1ubuntu3 500   <--- No isse
        500 focal/main amd64 Packages
        100 /var/lib/dpkg/status

    Customer is considering the patch of the Ubuntu package is affecting this compile error.

    Anyway, customer was able to resolve this error.

    Thank you a lot.


    Best regards,


  • Miyazaki-san,

    thanks for the additional insight/investigation. We also concluded the issues are related to a recent Git update. More information has been compiled here in this FAQ:

    Regards, Andreas