This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Yocto: ti-cg-xml fails at do_install()

Hi Everyone,

when trying to build meta-ti-extras/recipes-ti/devtools/ the recipe fails on my build machine during the do_install() step. I figured out, that the Linux - always fails to execute with errno 127 which leads to an error in the do_install() step because there are not files unpacked which could be installed.

The build host is running ubuntu 20.04. Because the cgxml installer is a 32 bit binary, I have installed libc6-i386 and so /lib/ is correctly linked to /lib32/

Does anyone have an idea how to get the cgxml installer correctly running on my machine?



  • Hi Marco,

    are you trying to build any of the TI standard images?

    Have you tried installing all the system dependencies as per for example?

    Also note that our current SDKs officially only support Ubuntu 18.04 (which they are tested against), so you may want to try the "Building the SDK" steps outlined in the SDK doc on Ubuntu 18.04.

    Regards, Andreas

  • Hi Andreas,

    thank you for responding so fast! I am currently trying to build a TQ Systems image for an evaluation board. Unfortunately the guys at TQ couldn't help me in that case so I turned to you.

    I have now set up a docker container with ubuntu 18.04 and all prerequisites listed in your link but the recipe still fails because the cgxml installer returns with error code 127. Maybe a strace could help to find the cause?

    $ strace ./ 
    execve("./", ["./cgxml-2.61.00-linux-installer."...], 0x7fff26b5ef30 /* 35 vars */) = 0
    strace: [ Process PID=6246 runs in 32 bit mode. ]
    mmap(0xc6e000, 4096, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0xc6e000) = 0xc6e000
    readlink("/proc/self/exe", "/workspaces/ci-meta-tq/tqma65xx_"..., 4096) = 120
    mmap(0x8048000, 1116885, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x8048000
    mprotect(0x8048000, 1116882, PROT_READ|PROT_EXEC) = 0
    mmap(0x8159000, 45115, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x8159000
    mprotect(0x8159000, 45112, PROT_READ|PROT_WRITE) = 0
    mmap(0x8165000, 15356, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x8165000
    brk(0x8169000)                          = 0x827f000
    open("/lib/", O_RDONLY)    = 3
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p\f\0\0004\0\0\0"..., 512) = 512
    mmap(NULL, 163840, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xf7fc4000
    mmap(0xf7fc4000, 152640, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED, 3, 0) = 0xf7fc4000
    mmap(0xf7fea000, 6260, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3, 0x25000) = -1 EBADF (Bad file descriptor)
    exit(127)                               = ?
    +++ exited with 127 +++



  • Hi Marco,

    thanks for the extra details. I was out of the office for a few days but I'm back now. Let me see if I can re-create this. Give me a day or two. Will report back,

    Regards, Andreas

  • Hi Marco,

    I just tried building the tool under Ubuntu 18.04 x64 and then was able to run it without any issues.

    a0797059@jiji:~/tisdk/am335x-evm/build (master)
    $ MACHINE=am335x-evm bitbake ti-cg-xml


    a0797059@jiji:~/tisdk/am335x-evm/build (master)
    $ ./arago-tmp-external-arm-glibc/work/armv7at2hf-neon-linux-gnueabi/ti-cg-xml/1_2.61.00-r0/
    Welcome to the Code Generation Tools XML Processing Scripts Setup Wizard.

    Please read the following License Agreement. You must accept the terms of this
    agreement before continuing with the installation.

    Press [Enter] to continue:

    Can you make sure you have all the TI SDK-recommended prerequisites installed? Those are documented at Especially the last few packages listed are very likely the solution you need:

    For Ubuntu 16.04 and 18.04, please run the following:

    $ sudo apt-get install build-essential autoconf automake bison flex libssl-dev bc u-boot-tools python diffstat texinfo gawk chrpath dos2unix wget unzip socat doxygen libc6:i386 libncurses5:i386 libstdc++6:i386 libz1:i386 g++-multilib

    Regards, Andreas