This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

AM5728: IPUx_Cx Core Image Loading Problem.

Part Number: AM5728


This is the environment that I did : 

  1. CCS : v9.3.0
  2. SYS/BIOS :
  3. XDCTools :
  4. PDK : 1.0.17
  5. Compiler : TI v18.12.5.LTS
  6. evmBoard : IDK5728

I tried SYS/BIOS a typical example on IDK5728 evaluation board (IPU1_C0 Core).

The example was running good. Then, I tried to change the memory region from 0x8000_0000 to 0xA000_0000.

The J-tag emulator returned error messages when I load the image as below:

The text message detailed:

Cortex_M4_IPU1_C0: Can't Run Target CPU: (Error -1268 @ 0x1090001) Device is locked up in Hard Fault or in NMI. Reset the device, and retry the operation. If error persists, confirm configuration, power-cycle the board, and/or try more reliable JTAG settings (e.g. lower TCLK). (Emulation package

So, I hope to run the code on the memory region (0xA000_0000).

This is the memory map file that the compiler was generated.

When the image was not working :


When the image was working :


Is there something to do more to run code that memory region (0xA000_0000)?

Best regards.