This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LP-AM263: Running the example "FSI loopback mode with DMA" multiple times fails

Part Number: LP-AM263

At the moment we are testing some source examples from SDK version 8.6 with LP-AM263x.
Our focus is on the FSI interface now.

I played with the FSI interface in loopback mode and DMA support (we tried the example from the SDK).
We had problems with the example in SDK version 8.5, but with SDK 8.6 the examples plays correct now.

In the next step, I tried to execute the fsi loopback dma example in an endless while loop.

Therefore I modifed the main loop of the example in that way:

I started a  debug session, the debugger stops at the begin of the main function.

Now I placed a breakpoint the the function fsi_loopback_dma_main() and added the following variables to the watch expressions:

In the next step I started execution, the debugger stops the first time in front of the function fsi_loopback_dma_main()

In the next step I used the Step-Over function (F6) to execute the function fsi_loopback_dma_main() the first time.
The first execution functions without any problems, I got the following terminal output (SBL NULL log is included too)

The debugger stops again in front of the function fsi_loopback_dma_main().
Now I press F6/Step over again. The second execution of the function fails, terminal log is like this:

The function stops at the comparision of transmit and receive data of the FSI interface, I tried to check the receive data and saw, that the receive data have an offset.
gRxBufData[0] should start with content 1, at the first execution of the function fsi_loopback_dma_main() there is no problem.

But with the second exection, the first received value is 33 (offset 32), all following values have this offset...

Now I tried to find the reason for this behaviour, but I can't find any problem in the initialisation of the FSI/DMA.

What can be the reason?

Best regards

Jo Scho

  • Hi Jo,

    I can reproduce the problem on AM263x LP. It looks like a bug. It only happens for the FSI DMA loopback example, the interrupt and the polling examples work fine with the similar change.

    I have filed a JIRA ticket for this issue. Will discuss with the software team to root cause it and fix it as soon as possible. Thanks.