This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

AM623: error message after loading m4 firmware

Part Number: AM623

Hi Expert,

I am using SDK 08.06.00.42 in our customer board now. I try to copy am62-mcu-m4f0_0-fw from Yocto release. It can solve the firmware load error issue. But two errors always show now. How can I fix these errors?

[ 6.292708] sdhci-am654 fa10000.mmc: error -110 requesting status
[ 6.292984] mmc0: cache flush error -110

sometimes also show this error, "blk_update_request: I/O error, dev mmcblk0, sector 12587008 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0".

[  OK  ] Created slice system-systemd\x2dbacklight.slice.
[  OK  ] Created slice system-systemd\x2dfsck.slice.
[    6.154693] remoteproc remoteproc0: 5000000.m4fss is available
[  OK  ] Listening on fsck to fsckd communication Socket.
[    6.188130] remoteproc remoteproc0: powering up 5000000.m4fss
[    6.194118] remoteproc remoteproc0: Booting fw image am62-mcu-m4f0_0-fw, size 54860
         Starting Load/Save Screen …ness of backlight:backlight...
         Starting Hostname Service...
[    6.240457]  remoteproc0#vdev0buffer: assigned reserved memory node m4f-dma-memory@9cb00000
[    6.252841] platform 78000000.r5f: R5F core may have been powered on by a different host, programmed state (0) != actual state (1)
[    6.264865]  remoteproc0#vdev0buffer: registered virtio0 (type 7)
[    6.282160] remoteproc remoteproc0: remote processor 5000000.m4fss is now up
[    6.292708] sdhci-am654 fa10000.mmc: error -110 requesting status
[    6.292984] mmc0: cache flush error -110
[    6.300471] platform 78000000.r5f: configured R5F for IPC-only mode
         Starting Network Name Resolution...
[    6.337372] platform 78000000.r5f: assigned reserved memory node r5f-dma-memory@9da00000

[    6.356504] remoteproc remoteproc1: 78000000.r5f is available
[    6.363009] remoteproc remoteproc1: attaching to 78000000.r5f
[    6.363233] platform 78000000.r5f: R5F core initialized in IPC-only mode
[    6.363250]  remoteproc1#vdev0buffer: assigned reserved memory node r5f-dma-memory@9da00000
[    6.363404]  remoteproc1#vdev0buffer: registered virtio1 (type 7)
[    6.363410] remoteproc remoteproc1: remote processor 78000000.r5f is now attached
[  OK  ] Started LSB: Load kernel m…ded to enable cpufreq scaling.
[    6.438164] random: crng init done
[    6.441640] random: 138 urandom warning(s) missed due to ratelimiting
[  OK  ] Finished Load/Save Screen …htness of backlight:backlight.
         Starting LSB: set CPUFreq kernel parameters...
[    6.678880] IPv6: ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
[    7.110743] remoteproc remoteproc2: 30074000.pru is available
[    7.119451] remoteproc remoteproc3: 30078000.pru is available
[  OK  ] Finished Load/Save Random Seed.
[  OK  ] Started Hostname Service.
[    7.237490] cdns-csi2rx: probe of 30101000.csi-bridge failed with error -22
[  OK  ] Started LSB: set CPUFreq kernel parameters.
[    7.318007] virtio_rpmsg_bus virtio0: rpmsg host is online
[    7.318789] virtio_rpmsg_bus virtio0: creating channel ti.ipc4.ping-pong addr 0xd
[    7.334428] sdhci-am654 fa10000.mmc: error -110 requesting status
[    7.336173] virtio_rpmsg_bus virtio0: creating channel rpmsg_chrdev addr 0xe
[    7.348125] mmc0: cache flush error -110
[    7.358499] virtio_rpmsg_bus virtio1: rpmsg host is online
[    7.364231] virtio_rpmsg_bus virtio1: creating channel ti.ipc4.ping-pong addr 0xd
[    7.372575] virtio_rpmsg_bus virtio1: creating channel rpmsg_chrdev addr 0xe
[    7.470979] mmc0: unexpected status 0x800900 after switch
[    7.477095] mmc0: switch to bus width 8 failed
[    7.483839] mmc0: switch to bus width 4 failed
[    7.493856] mmc0: mmc_select_hs200 failed, error -110
[    7.498930] mmc0: tried to HW reset card, got error -110
[    7.504253] mmcblk0: recovery failed!
[    7.508046] blk_update_request: I/O error, dev mmcblk0, sector 12587008 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0

Best regards,

Neil