This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

PROCESSOR-SDK-J721E: Processors forum

Part Number: PROCESSOR-SDK-J721E

Tool/software:

Hello,

I am encountering the following error when I try to build the vision_apps:

/home/<user>/ti/ti-processor-sdk-rtos-j721e-evm-09_02_00_05_personal/vision_apps/out/J721E/R5F/FREERTOS/release/vx_app_rtos_linux_mcu2_0.out

undefined first referenced
symbol in file
--------- ----------------
appDssDefaultInit                    /home/<user>/ti/ti-processor-sdk-rtos-j721e-evm-09_02_00_05_personal/vision_apps/out/J721E/R5F/FREERTOS/release/app_rtos_common_mcu2_0.lib<app_init.obj>
appDssDefaultSetDefaultPrm /home/<user>/ti/ti-processor-sdk-rtos-j721e-evm-09_02_00_05_personal/vision_apps/out/J721E/R5F/FREERTOS/release/app_rtos_common_mcu2_0.lib<app_init.obj>
appEthFwInit                           /home/<user>/ti/ti-processor-sdk-rtos-j721e-evm-09_02_00_05_personal/vision_apps/out/J721E/R5F/FREERTOS/release/app_rtos_common_mcu2_0.lib<app_init.obj>
appEthFwRemoteServerInit    /home/<user>/ti/ti-processor-sdk-rtos-j721e-evm-09_02_00_05_personal/vision_apps/out/J721E/R5F/FREERTOS/release/app_rtos_common_mcu2_0.lib<app_init.obj>

error: unresolved symbols remain
error: errors encountered during linking;
"/home/<user>/ti/ti-processor-sdk-rtos-j721e-evm-09_02_00_05_personal/vision_
apps/out/J721E/R5F/FREERTOS/release/vx_app_rtos_linux_mcu2_0.out" not built
tiarmclang: error: tiarmlnk command failed with exit code 1 (use -v to see invocation)

SDK: ti-processor-sdk-rtos-j721e-evm-09_02_00_05

OS: Ubuntu 22.04

Thanks for help in advance!

Regards,
Tamas