This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

could not Flashing the image to NAND Flash

I’m trying to burn the image(MLO) to the NAND Flash following to the AM335x CCS Flashing Tools Guide.

Things seem OK, for example,

1. the initialization was fine

2. OK to get proper device ID etc details

2. OK to erase the whole Flash

3. etc.

However it's hanging when enter "Flashing the image . . ."

It should print out followings and never got those messages

Application is successfully flashed

NAND boot preparation was successful!

I have also tried to rebuild the Flash writer project and still the same proble. I like to get some help from you and TI. Thank you.

  • Hi,

    Please describe in details the steps you follow to do the flashing. Also post which CCS version / GEL files you are using.

  • 1. Create new Target Configurations pane by File > New > Target configuration file.
    2. Name it as AM335x.ccxml and click on Finish.
    3. In the new Target configuration select Basic pane and select connection type as TI XDS560 Emulator and
    device type as AM335x by checking the box.
    4. Save the target configuration, eg: AM335x.ccxml.
    5. Select coretex A8 core in the advanced pane and update the initialization script with AM335x.gel file.
    6. Save the target configuration.
    • Select Debug in CCS if not there already: View-> Debug
    • Select View -> Target Configurations. Expand User defined till you reach AM335x.ccxml.
    • Right click and click "Launch Selected Configuration".
    • This should launch debug session.
    • In Debug view, (scroll till the end) Select "TI XDS560 Emulator_0/Cortex A8" connection.
    • Right click and select "Set Debug Scope" option. This will make remove all the cores except Cortex A8 from the
    debug view.
    • Right click on the Cortex A8 core listed in Debug view and click on "Connect Target".
    • Run the initialization script under scripts tab, AM335x System initialization ==>>

    7. Load Gel file "beaglebone.gel"

    8. To initialize EVM select the AM335x_EVM_Initialization under AM335x System Initialization

    9 Load nand-flash-writer.out and run it. nand-flash-writer.out

    10. click on "resume" and following menu printed out from the console

    Choose your operation
    Enter 1 ---> To Flash an Image
    Enter 2 ---> To ERASE the whole NAND
    Enter 3 ---> To EXIT

    11. enter "2" and got "Performing Global Nand Erase ... done" message print out on the console

    12. enter "1" and things were OK until message "Flashing image . . ." print out - hanging there forever


    CCS5.5.0.00077 is used. Thank you.

  • Ying Ye said:
    12. enter "3" and hanging forever ...

    Shouldn't you enter "1"? Entering "3" exits the program.