This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

RTOS/TMDXSK437X: Example CCS8 Project debug returns "Device Held In Reset" Error

Part Number: TMDXSK437X
Other Parts Discussed in Thread: SYSBIOS

Tool/software: TI-RTOS

Testing with a new (to us) SKAM437X starting with TI examples results in issues we have not been able to understand.  We have started by building the TI furnished examples.

The "task_SK_AM437X_CortexA" example fails at the start of debugging with the "Device is held in reset....." error. The benchmark, clock, and hello examples all debug successfully.  The onboard XDS100v2 debugger is used.  All projects are downloaded from Resource Explorer Classic from the SK_AM437X . CortexA, GNU, Generic Examples and are not modified.   Other examples also fail.

Many repeat over multiple days   Tried power cycles, holding Power On button until debug start , always with same results.  The projects which work, always work.  The projects which fail, always fail.

Intended use of example project is the initial base from which to build a TI-RTOS project to support existing TI_Tiva system with Ethernet communications, computation, etc.


Forum searches note similar issues, but  I did not see a post where some CCS projects always work,  and yet other CCS projects had the "Device Held in Reset" error.  The fact that some example projects always work would seem to eliminate hardware issues.

Any assistance would, of course, be greatly appreciated.


  • Hi Randy,

    Do you use the latest version of the AM437x PSDK RTOS v5.02?

    This RTOS version should be used with:

    CCS 8.2.0
    SYS/BIOS 6.73.1
    XDCTOOLS 3.50.08

    I see you are using XDC 3.51, not 3.50

    Can you try with XDCTOOLS 3.50.08 (it comes with PSDK RTOS v5.02), will be there any improvement?

  • Hi Pavel,

    Thanks (a lot) for your help.

    I am uncertain how to determine what version of AM437x PSDK I am using.  I see I have processor_sdk_rtos_am437x_5_02_00_10 directory in the /ti install directory.  I think this means I have that version installed.  My confusion is that in CCS8 when I examine the task properties (task_SK_AM437X_CortexA / Products)  I see am437x PDK 1.0.13 as the only version.  AND I do NOT see any SDKs for the 437x! 

    So I maybe I do not actually the AM437X PSDK v5.02 installed?  I am guessing that is my issue.  If so, I downloaded the SDK install package, executed the install exe, but did not get the package installed into CCS?

    Also, as a teaching moment, Is the PSDK name you used in your reply  the same as SDK? 

    Trying the XDCTOOLS 3.50.08 had no effect.



  • Hi Pavel,
    I am aware (now) that the PDK is a part of the SDK, but I am still stuck. I am reviewing the Processor SDK RTOS Software Developer's Guide yet again. I am sure that I have missed an important step.

  • Randy,

    I made a search in below resources, but nowhere I am able to to find "task_SK_AM437X_CortexA" example.


    Can you provide more details about where exactly you find such example?

    Meanwhile I can suggest you to check below Cortex-A9 related examples:


  • Hi Pavel,

    The example task_SK_AM437X_CortexA is the old school path through "TI Resource Explorer /  SYSBios / AM43xx /  SK_AM437X / CortexA / GNU / Generic /  Task Mutex Example". not in the PDK examples.

    I have since (just) been able to (almost) eliminate the "device help in reset" issue by following a very careful sequence when importing a project and setting up a workspace. I still do not know what i was doing wrong for the (probably) hundred times I tried before. For whatever it is worth, here are some comments.

    * Once I failed to "get the project setup" correct on the first try, I could never correct the failure to start a debug session without deleting and re-starting the project which I did in a new workspace.

    * I have since changed from having multiple CCS projects in the same workspace to using a single project in a workspace which might be the fix but I used multiple projects in a single workspace for years.

    * I had the same issue on both SK437x and Beaglebone Black hardware and PDK examples.  The issue was not related to that specific project but multiple PDK examples.

    Thanks for your attention and help,