This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Linux/AM3358: Kernel boot fails

Part Number: AM3358

Tool/software: Linux


I am workiing on running Embedded Linux on beaglebone (AM335x).I compiled all the components manually i.e. U-boot, Kernel, File System (Busybox). Then partitioned SD Card into two partitions (Fat16, Ext3). I copied MLO, u-boot.img, uEnv.txt into partition 1 (FAT16) and the remaining kernel uImage, dtb and File System into partition 2 (Ext3). The u-boot read is good but the kernel image is not loaded. I paused the u-boot and tried to load the kernel image via load command but it says "** No partition table - mmc 2 **".

I tried to partition SD card many time but useless.

Following are the complete logs:

U-Boot SPL 2019.07-rc2 (May 26 2019 - 15:53:43 +0500)

Trying to boot from MMC1

U-Boot 2019.07-rc2 (May 26 2019 - 15:53:43 +0500)

CPU  : AM335X-GP rev 2.1

Model: TI AM335x BeagleBone Black

DRAM:  512 MiB


Loading Environment from FAT... ** No partition table - mmc 0 **

Loading Environment from MMC... *** Warning - bad CRC, using default environment

<ethaddr> not set. Validating first E-fuse MAC

Net:   Could not get PHY for ethernet@4a100000: addr 0

eth0: ethernet@4a100000

Warning: usb_ether MAC addresses don't match:

Address in ROM is          de:ad:be:ef:00:01

Address in environment is  f4:5e:ab:f8:cd:fa

eth1: usb_ether

Press SPACE to abort autoboot in 2 seconds

switch to partitions #0, OK

mmc0 is current device

SD/MMC found on device 0

** Unrecognized filesystem type **

** Unrecognized filesystem type **

switch to partitions #0, OK

mmc0 is current device

Scanning mmc 0:1...

switch to partitions #0, OK

mmc0 is current device

SD/MMC found on device 0

switch to partitions #0, OK

mmc0 is current device

Scanning mmc 0:1...

switch to partitions #0, OK

mmc1(part 0) is current device

SD/MMC found on device 1

** No partition table - mmc 1 **

** No partition table - mmc 1 **

## Error: "bootcmd_nand0" not defined

starting USB...

Bus usb@47401800: Port not available.

using musb-hdrc, OUT ep1out IN ep1in STATUS ep2in

MAC de:ad:be:ef:00:01

HOST MAC de:ad:be:ef:00:00

RNDIS ready

musb-hdrc: peripheral reset irq lost!

  • Hello kowalski,

    The issue you are seeing can be somehow related with the U-Boot 2019.07-rc2 version you are using. As a starting point, can you check this behavior with the U-Boot from the latest Processor SDK? This test should reveal whether you are doing something wrong while partitioning the SD card or the U-Boot version you are using is broken.

    Best regards,

  • I can't locate u-boot binaries etc. in you given link please.

    Also, just to test various scenarios i conducted the following tests:

    Attempt 1: Format sdcard and created new partitions via gparted software, then copied all the components to respective partitions.

    Results: FAILED

    Attempt 1: Rebuild all software components and installed them directly in sdcard.

    Results: FAILED

    Attempt 3: Took prebuilt Kernel and dtb images from here and kept the u-boot (own built) same.

    Results: FAILED

    Attempt 4: Kept the Kernel and RFS own built and used MLO and u-boot.img from the given link.

    Results: WORKED


    There is either some problem with the latest version of u-boot or build process... I am confused how to narrow down the problem.


  • These are the images. Please try them.

  • Thanks I narrow down the issue and resolved it. I recompiled u-boot.. but guess where was the problem. The beaglebone configuration file is am335_boneblack_defconfig but it seems to be incompatible. I recompiled the u-boot with EVM config file i.e. am335x_evm_defconfig and the issue resolved.

  • I am happy to hear that you have resolved the issue.