This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

AM5728: Minicom Not working on custom AM5728

Part Number: AM5728
Other Parts Discussed in Thread: AM5729


I have a custom board based on Ti - AM5728 SoC and below is the attached diagram for the connection of the Minicom port of SoC to the PC/Laptop. 

Currently, the custom board is a bare board with no u-boot, driver, kernel, filesystem loaded.  I am trying to run the diagnostic on the bare board with .out files and Code composer studio. 

As per my understanding and when I ran the diagnostics on the AM5728 evaluation module, the test program (.out file)  is loaded through Code composer studio, but the results and print of the test are printed in the terminal shell connected via minicom.

The same thing I am trying to do on custom bare board, loading and running the test program from CCS but want to view the output on the minicom console. The minicom console shows offline and no output is getting displayed, but on CCS, it shows that the test program is running.


Sahil Kalra

  • Hello,

    This is a gentle reminder.

    Please provide resolution to this query


    Sahil Kalra

  • Hello,

    I am also facing this issue. I am not getting any messages on minicom.

    Kindly suggest.

  • Are you referring to the header P10 on the AM5729 EVM (that connects with UART3)?  Do you have an EVM, and confirmed UART3 is in fact used for the diagnostic code you are attempting to run?

    Are you attempting to run the exact same binary (.out) as the AM5728 EVM, or have you made changes/rebuilt the binary? There could be many changes between the custom board and the EVM that force changes in the diagnostic binary.  For example, did the reference input clock change to the AM57x devices?  This might cause the baud rate to be different from expected.  Did the external DDR memory change?  This might cause the program to not execute correctly.  Are you using the exact same pins for UART3?

  • Hello Robert,

    Yes, I have an AM5728 EVM and I am able to run diagnostic code on it successfully. However, When I am trying to run the diagnostic code with few changes in it on the custom bare board, no prints are being displayed on the minicom console. 

    Following are the changes/differences between EVM and custom bare board:

    1. RAM in EVM is 2GB (32*16*8)  and on the custom bare board, it is 4GB (64*16*8).

    2. On the EVM, DDR frequency is 532 MHz, but on custom board, it is 400 MHz.

    3. Changes in the code related to above points were made in board library, CCS GEL files, pinmux, MEM test in tester software.

    4. Also, in the EVM minicom is available through serial JTAG port, but in the custom board, RS-32 converter is connected to the serial port and provided as mini-usb port outside. Please refer to the diagram, attached in the query above.

    Few more observations:

    1. I am assuming the input clock shall remain same  for both EVM and custom board.

    2. I also tried the inbuilt script present in CCS like -  memory test and temperature sensor reading. They are working fine on the custom board, however, memory test gives 2GB as output even though 4GB is connected. 

    Is it possible to see the prints of the tester software on the CCS console ? 


    Sahil Kalra

  • What rate are you attempting to transmit on UART console?  I believe the EVM diagnostic is default to 115200 baud.  Can the RS-232 converter support that rate? 

    Have you confirmed the UART portion of the design is unchanged between EVM and custom board?  You state minicom shows as 'offline'.  I'm not sure what that means.