This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

AM5729: how to use 4 eves in am5729 ?

Prodigy 110 points

Replies: 12

Views: 123

Part Number: AM5729

hello everybody:

i use beagleboard x15 ,i run example in sdk, but ...

how can i use it?

  • Hi, are you using Linux PSDK 6.x and did you create SD card image with windows image? .. if so, this could be a known issue, and a workaround is to copy a file as shown below:

    cp /lib/firmware/dra7-ipu1-fw.xem4.opencl-monitor /run/media/mmcblk0p1/dra7-ipu1-fw.xem4

    For additional details, you can check may 28 post in below E2E:

    thank you,

    Paula

  • In reply to Paula Carrillo:

    hi paula :

    thank you for replay ,I use linux sdk 6.x,use uart login ,I copy the file ,reboot,

             /etc/init.d/weston start

    but .. stop there

  • In reply to Paula Carrillo:

    hi paula :

    thank you for replay ,I use linux sdk 6.x,use uart login ,I copy the file ,reboot,

             /etc/init.d/weston start

    but .. stop there

  • In reply to Paula Carrillo:

    hi paula:

    I create sd card again with sdk creat-sd.sh ,and copy the file to mmcblk0p1, now I run success with dsp,but when i run J11v2 with 2 dsp + 2 eve ,failed 

    thank you ! hope for your reply

  • In reply to user5281189:

    Hi, which AM57x do you have? how many cores EVEs?... if you don't know can you please run "/usr/share/ti/examples/opencl/platforms/platforms"?.

    If you have EVEs cores it would print below line per core, if you don't see below printed twice or four times, then you only have DSPs cores. 

    • DEVICE: TI Embedded Vision Engine (EVE)

    thank you,

    Paula

  • In reply to Paula Carrillo:

      i use  am5729 with 4 eves

  • In reply to user5281189:

    Hi, have you tried any other demo?.. it is pretty odd that DSP-only demo is hanging.. could we try to run DSP+EVE? 

    ./tidl_classification -g 2 -d 1 -e 2 -l ./imagenet.txt -s ./classlist.txt -i 1 -c ./stream_config_j11_v2.txt
    ./tidl_classification -g 2 -d 1 -e 2 -l ./imagenet.txt -s ./classlist.txt -i ./clips/test10.mp4 -c ./stream_config_j11_v2.txt

    Thank you,
    Paula
  • In reply to Paula Carrillo:

    hi , when i  run this demo that you give me ,print this

  • In reply to user5281189:

    Hi, it is probably related to CMEM.. could you please re-run "/usr/share/ti/examples/opencl/platforms/platforms" and copy the results here?.. There are environmental variables that we can change to setup DSP and EVE heap sizes accordingly with your platform memory.. if you want to take a look to some examples, TIDL demos GUI wrapper scripts are in rootfs partition /usr/bin/runTidl*, for example runTidlLiveCam_lg2.sh.

    Also, does TIDL GUI demos (Deep Learning gui sub-menu)  run OK?

    thank you,

    Paula

  • In reply to Paula Carrillo:

    Hi Paula, thank you very much for your reply,if i run any demos with eve ,all failed.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.