This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

[FAQ] Compiler: TDA2x: Sometime Gstreamer video is not displaying in monitor when I used kmssink

Genius 10820 points

Replies: 1

Views: 59

Tool/software: TI C/C++ Compiler

Hi,

Case 1: Getting Permission denied error for the below pipeline

gst-launch-1.0 filesrc location= /usr/share/ti/video/TearOfSteel-Short-1920x800.mov ! qtdemux name=demux demux.video_0 ! queue ! h264parse ! ducatih264dec ! vpe ! 'video/x-raw, format=(string)NV12, width=(int)1920, height=(int)1280' ! kmssink

Setting pipeline to PAUSED ...
[ 2018.997158] omap-iommu 55082000.mmu: 55082000.mmu: version 2.1
Pipeline is PREROLLING ...
ERROR: from element /GstPipeline:pipeline0/GstKMSSink:kmssink0: GStreamer encountered a general resource error.
Additional debug info:
../../../gst-plugins-bad-1.14.4/sys/kms/gstkmssink.c(1625): gst_kms_sink_show_frame (): /GstPipeline:pipeline0/GstKMSSink:kmssink0:
drmModeSetPlane failed: Permission denied (-13)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...

Case 2: No error & no video displaying

gst-launch-1.0 filesrc location= /usr/share/ti/video/TearOfSteel-Short-1920x800.mov ! qtdemux name=demux demux.video_0 ! queue ! h264parse ! ducatih264dec ! vpe ! 'video/x-raw, format=(string)NV12, width=(int)1920, height=(int)1280' ! kmssink

Setting pipeline to PAUSED ...
[ 2868.190356] omap-iommu 55082000.mmu: 55082000.mmu: version 2.1
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

What are the steps to overcome this issue?

Thanks

Gaviraju

  • Hi,

    Case 1: We will get a permission denied error if the Weston application running, so we need to stop the Weston application before running the Gstreamer pipeline with the kmssink

    The command to stop the Weston application is

    • /etc/init.d/weston stop

    Case 2: Seems the Matrix-GUI application running in the foreground, so we need to stop this application before running the Gstreamer pipeline with the kmssink

    The command to stop the Matrix-GUI application is

    • /etc/init.d/matrix-gui-2.0 stop

    Thanks

    Gaviraju

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.