This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

ADS58J89: I cannot make ADS58J89 work with TSW14J65

Prodigy 120 points

Replies: 9

Views: 410

Part Number: ADS58J89

Hello,

I have a ADS58J89 hooked up to a TSW14J65.

I followed the instructions provided in the datasheet of the both modules to install HSDC pro (version U) and ADS58J8x EVM GUI (Version A).

First I clicked on device reset on ADS58J88 Tab on the ADSJ58J8x GUI. Also, I clicked on reset for LMK04828 PLL1 and PLL2.

There are several problems.

1- On HSDC pro, when I click on select ADC, I cannot find ADS58J8x_LMF_442. I only can find ADS58Jx_LMF442. Is that ok?

2- On ADS58J8x EVM GUI, ADS58J88/JESD configuration I put F=1, K=32 and L=4

In the user manual of ADS58J8x EVM, on the section titled "JESD204B controls" says the capture card must be configured with same parameters of ADS58J89. How to put same values in the capture card? 

3- On the low level tab in ADS58J8x EVM GUI, load config, there are two options : ADS58J88_500M_442.cfg , and ADS58J88_500M_841.cfg , but the user manual says there must be ADS58J88_500M_442.cfg and ADS58J88_500M_881.cfg . What is this difference for? I want to sample with Fs=250M.

4- After loading either ADS58J88_500M_442.cfg , or ADS58J88_500M_841.cfg, here is status of my LEDs on ADS58J88:

D1 : on

D4 : on

D3: on 

I tried to see  SYSREF signal by connecting either J4 or J17 to an Oscope/spectrum analyzer, but I couldnt see any signal. (This state is before checking the SDCLKout_PD in block of controls for clocks CLKout2 and 3, which turns SYSREF off)

5- I put Fs=250M on HSDC pro. and pushed on Capture, but I got an error. I have attached a screen shot of it here.

I followed the instructions and here is status of the LEDs:  D4 on TSW14J56 is not blinking. D3 on ADS58J8x is on!

Would you help me to make it work?

Thanks

Farshid

  • Hi Farshid,

    For this device you have to use a different firmware.
    On the menu bar, click on Instrument Options>> Download Firmware and select the firmware with the name: TSW14J56REVD_RX_ALT_SYNC_LVDS_FIRMWARE.

    After loading the new firmware, configure the ADC again and try to capture data.

    Thanks,
    Eben.
  • In reply to Ebenezer Dwobeng:

    Hi Eben,

    Thanks for the reply.

    I used the new firmware in HSDC pro, but a new error popped up. Here it is:

    Also, still D4 in capture card is off and not blinking.

    The more important point is I monitored J4 and J17 (SDCLKOUT7) by an oscilloscope, but it's not showing anything. I think the ADC is not sending any sync signal out.

    How can I solve this issue?

    Thanks

  • In reply to Farshid Tamjid:

    Hi Farshid,

    Before programming the ADC make sure to push the ADC Reset button (SW1).

    Thanks,
    Eben.
  • In reply to Ebenezer Dwobeng:

    Hi Eben,

    Each time when I turn the ADC on, first I reset it. But, still it doesnt work. I think the ADC doesnt send any sync signal out. How can I fix this problem?

    Thanks
  • In reply to Farshid Tamjid:

    Hi Farshid,

    Can you confirm the current limit of power supply to TSW14J56 is more than 3A? I am also putting together a setup in the lab with the same version of software you have to debug further if increasing the current limit does not help.

    Thanks,

    Eben.

  • In reply to Ebenezer Dwobeng:

    Hi Eben,

    Well both the ADC and capture card came with their own power supply. They both have
    PHIHONG swtiching power supply
    Model: PSC15A-050
    OUTPUT: 5V, 3A

    Regards
    Farshid

  • In reply to Farshid Tamjid:

    Hi Farshid,

    The right .ini file for ADS58J89 was not included in v5p0 of HSDCPRO. I will have them added to the next release.

    But you can use the ini file ADS54j54_LMF_442 also for your testing because this device JESD204B interface is identical to ADS58J89.

    Thanks,

    Eben.

  • In reply to Ebenezer Dwobeng:

    Hi Eben,

    Thanks for the help. It started working when I chose ADS54J54.

    I have another question too. How can we export real-time data from four channels of ADS58J89 and import in Matlab? Does TI have any interface for it?

    Thanks

    Farshid

  • In reply to Farshid Tamjid:

    Hi Farshid,

    Please start a new thread for this new question so that we can close this one. It has been opened for a while now.

    Thanks,
    Eben.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.