• Resolved

DAC38RF80: Single DAC B register settings

Prodigy 190 points

Replies: 9

Views: 117

Part Number: DAC38RF80

Hello,

In a previous post (https://e2e.ti.com/support/rf-microwave/f/220/t/903004) I asked if it was possible to set up the DAC38RF80 to be single DAC mode, so all 8 lanes are for a single DUC (LMFS = 8212), and have that output on DAC channel B. I do not care if this data is also coming out of DAC channel A. At the bottom of the post I received an answer of yes, with the data going through DUC A and being summed to go out of DAC B. Picture I was provided below:

I would like to try this on the DAC38RF80EVM using the provided GUI. However, when I have the "# of DACs" drop down list selected at Single(DAC A), I am unable to access the Digital(DAC B) tab, which is where the control for the summation block is. Pictures below:

Is the solution to this problem to manually enter the low level control register value to turn on the summation block (should just be setting bit 2 in register 0x219)? Or is there a way to remedy this that I can't find?

I am currently interfacing the EVM with an FPGA. I have a build that works for the DUAL DAC configuration and before I make a build for Single DAC mode I want to make sure this is even possible to do. So a solution would be great, but if that solution could be tested/verified on the TI side of things that would be even better, though I understand if that isn't possible.

Thank you for the help,

Jacob

  • Hi Jacob,

    That is the correct solution to use. Setting bit 2 high in register 0x219 should set the path for the adjacent DAC for summation. I would also recommend that you make sure that DAC B is not put to sleep. Since, the setting is for Single(DAC A) the GUI might put DAC B to sleep. You should be able to make DAC B awake in the DAC overview tab.

    Regards,

    David Chaparro

  • In reply to David Chaparro:

    David,

    I was able to get a FPGA build to work with DAC channel A in Single DAC mode. I saw a sine wave coming out of DAC A and not DAC B. Then I tried the above steps. I verified that DAC A and B were not asleep, neither of the boxes were check and the low level register setting indicated they were not asleep:

    I then set the low level register 0x219 to be 0x000F. I just set all of the bits instead of just bit 2, but as I see it, that should be fine for what I want. Picture below:

    I still see a signal coming out of DAC A, but nothing out of DAC B. Did you verify that this configuration would work in hardware? I suspect the summation block for DAC B is actually turned off in Single DAC mode.

    Thank you,

    Jacob

  • In reply to Jacob Rohde:

    Hi Jacob,

    I did not get a chance test that configuration on hardware yet. I will look at the DAC now and see if I can find a working solution for this problem.

    Regards,

    David

  • In reply to David Chaparro:

    Thank you, David. I look forward to your response.

  • In reply to Jacob Rohde:

    Hi Jacob,

    We are currently trying a couple different methods to turn on the summation block, but it is taking a little longer than I had thought. I have asked someone who knows a little more about the device and they should be able to provide a little more insight. Are the settings in the GUI Overview screenshot the settings you are trying to run the DAC in? If not, what settings are you trying to have the DAC run with, that way we can make sure that the possible solution works for your settings.

    Regards,

    David

  • In reply to Jacob Rohde:

    Hi Jacob,

    We have found the correct way to get the output to go to both DAC channels. First because the DAC was set for Signle (DAC A) mode the clocks to DAC B were turned off. This is why setting bit 2 of 0x219 did not work. To turn the clocks back on for DAC B you can uncheck the single DAC box in the GUI, as seen below, or you can write 0x5820 to address 0x00. After that you still have to set bit 2 high for address 0x219 as you had done before. This will allow you to see the output on both channels of the DAC.

    Regards,

    David 

  • In reply to David Chaparro:

    David,

    The screenshot I took of the Quick Start Tab are the settings I am trying to get working. The sample rate and interpolation values aren't super important, but these were easy for me to implement on the eval board. The key is having it in Single DAC mode and getting an output on DAC channel B. Thank you.

    Jacob

  • In reply to Jacob Rohde:

    Jacob,

    I have tested the solution I described above with your settings and was able to get the output on channel B. It should work on your side, let me know if you face any problems with our solution.

    Regards,

    David

  • In reply to David Chaparro:

    David,

    What you suggested worked perfectly, thank you. I want to note that the signal coming out of DAC B is half power to the signal coming out of DAC A in this configuration. This is fine for my design, but I just wanted to let you know.

    Jacob