This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LDC-HALL-HMI-EVM: not able to establish communication with GUI


I have updated the drivers, tried different USB ports, used different cables, reviewed the COM port multiple times, and even experimented with different computers. I can't seem to get passed the error that says: 

Unknown EVM(s) Found!
The GUI could not detect a SCB/PAMB controller with a connected LDC-HALL-HMI-EVM daughtercard.

Please check that the appropriate EVM is connected or locate the correct EVM GUI from

If a LDC-HALL-HMI-EVM is connected, then you may attempt to connect to it by selecting "Options > Serial Port ..." from the menu bar.
Any ideas?
  • Hello, 

    Are you in operational mode 3 or 4 (half the button LEDs will be illuminated constantly)? Connect to the GUI requires the device to be in one of these modes for the SCB and device info to be properly communicated to the GUI. Modes 1 and 2 are designed for stand alone operation so they do not support the communication to the GUI. 

    If that isn't the issue, you may have to put the SCB in DFU mode before flashing it with the latest firmware. Instructions for this can be found in section 2.4 of the EVM User's Guide:

    Best Regards, 

    Justin Beigel

  • Justin,

    the board is not in the correct mode. The user's guide tells us we should press the knob down to switch modes, however nothing happens in my EVM when I do it. Is there something else I'm missing?

    Thank you!

  • Hello, 

    Is the first operational mode working as expected? (only one LED should light up when a button is pressed).

    Also, are the angle LEDs in the top right corner properly updating if you rotate the dial? 

    If both are working properly, there may be something preventing the dial from completely depressing. You may need to take the dial off and make sure there is nothing blocking the assembly and preventing the button to be fully depressed. 

    Best Regards, 

    Justin Beigel

  • No, the LED's are not responding to any commands. I see only 3 LED's lit up as the picture below shows:

    I removed the second cover, but could not find anything wrong with the button and the magnet. I tried with a separate magnet as well, without observing any different behavior. For the most part the board is unresponsive. I'll probe the signals with a scope next.


  • Hello, 

    This seems like it still may be more of a software issue. The parts on the board won't be responsive until they get their configuration from the SCB. This always happens at the start of the SCB firmware when it is powered on. I would try putting the SCB into DFU mode and letting the GUI re-flash the firmware. 

    Best Regards,