This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

IWRL1432BOOST: SPI disconnected and LUA script failure in mmWave Studio

Part Number: IWRL1432BOOST
Other Parts Discussed in Thread: DCA1000EVM, , IWR1843BOOST


I believe I have followed the instructions in the mmWave Studio setup for the DCA1000EVM and the IWRL1432BOOSTEVM.  I have connected all hardware and set the swtich settings according to the instructions.  I have also modified the "common_device_setup_77G.lua file as instructed in the user guide.  However, the script fails to run and I get an API failed error along with a SPIBUSY_TIMEOUT.  I have verified all 6 comm ports are active.  I am fairly new to radar and TI products, so I have included my hardware setup and the output screen snapshots to hopefully make it easier to get me pointed in the right direction.  Thank you for your help! 

Very Respectfully,


  • Hi,

    Thanks for your query. Please allow us a couple of days to respond


  • Abhishek,

    Thank you for the quick reply.  I appreciate you looking into my issue.  For reference, the mmWave Studio guide version I followed is this one:

    DCA1000EVM mmWave Studio Guide

    Thanks again.  I'll keep an eye out for your response.

    Have a great weekend!

  • Hello,

    Your switches are correct, and you are getting FPGA version which means you have a proper connection with the DCA1000 itself. SPI being busy is very interesting, does there happen to be an SD card inserted into the DCA1000? If so please remove it before trying again. But I will note that in your screenshot it says the SPI status is disconnected. Are you ever able to get it to connect?

    Best Regards,


  • Hi Pedrhom,

    Thanks for your reply.  I believe I tried everything the first time with the SD card removed, but I will take it out and reaffirm.  I have not been able to get the SPI status to show connected or the APPSS status to show active.  I will run through the procedure in the user guide one more time this morning just to confirm I am following it to the letter.

    I also have a IWRL1843BOOST which I will use with the other mmWave Studio version.  I am waiting on a second DCA1000EVM to assemble to the 1843EVM, so perhaps that will connect and provide some additional troubleshooting direction.

    Thanks again.  Details to follow.


  • Hi Pedrhom,

    Just a quick update:  I went through the mmWave Studio guide again and verified I was following the correct steps.  I ended up with the same result that SPI was disconnected and APPSS was inactive while using the IWRL1432BOOST EVM.

    I did receive the second DCA1000EVM and mounted the IWR1843BOOST EVM I had and was able to successfully connect and follow the user guide.  See attached graphic, which shows SPI is connected.  

    Could the 1432BOOSTEVM require a different firmware package? Perhaps an earlier version?  I am currently using the firmware found in my SDK folder: MMWAVE_L_SDK_05_04_00_01.

    Thanks again for your help.


  • Hello Craig,

    Does the second DCA1000 still show the same behavior with the IWRL1432BOOST EVM?

    Best Regards,