This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

IWRL1432BOOST: SDK Sample Programs Not Executing With Device Lock Up Error

Part Number: IWRL1432BOOST
Other Parts Discussed in Thread: SYSCONFIG

Tool/software:

Hi Team,

My customer is attempting to run the Hello World example as provided in the SDK on the IWRL1432BOOST EVM.

They have followed the steps from the documentation here: xWRL1432 MMWAVE-L-SDK: CCS Launch, Load and Run (ti.com)

They are running into the following error when they try to run the program.

Cortex_M4_0: Can't Run Target CPU:

(Error -1268 @ 0x1090001)

Device is locked up in Hard Fault or in NMI.

Reset the device, and retry the operation.

If error persists, confirm configuration, power-cycle the board,

and/or try more reliable JTAG settings (e.g. lower TCLK). (Emulation package 12.7.0.00105)

There is another thread indicating a similar issue here: IWRL6432BOOST: IWRL6432BOOST ccs Cortex_M4_0: Can't Run Target CPU: (Error -1268 @ 0x1090001) Device is locked up in Hard Fault or in NMI. - Sensors forum - Sensors - TI E2E support forums

However, when my customer repeatedly terminates the program and tries again, then sometimes the error goes away. But even if the error disappears, there is no hello world output in the console or terminal.

They also tried the GPIO LED blink example, but there seems to be no change in LED even though the example code should make it turn on for one second.

They also tried the no-rtos versions of the examples to no avail. 

Even when there is no error displayed, it appears that the program is not running correctly.

What is causing the device lock-up? Have they configured something incorrectly? 

Also on a separate but related note, when they build any sample projct on CCS, they get the warning below:

Warning:Product SysConfig v1.17.0 is not currently installed. A compatible version 1.20.0 will be used.

Should they revert to v1.17.0? Is this related to the error above?

Best regards,

Mari Tsunoda

  • Hi Mari, 

    I've been able to replicate the issue. Please advise the customer that after connecting to the target but before loading the code to the target they must press this button to perform a CPU reset. This should resolve the issue they are seeing for all the examples. 

    The SysConfig warning is not related to the issues they are seeing right now but generally it is best to have the same tool versions as what is expected since small changes could cause issues for some examples. 

    Regards,

    Josh

  • Hi Josh,

    Thanks for the quick response. Let me check with my customer.

    Best regards,

    Mari Tsunoda

  • Hi Mari, 

    Thanks. I will close this thread. Please respond here if the issue is not resolved and the thread will reopen. 

    Best Regards,

    Josh