This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/MMWAVEPOEEVM: Flashing/debugging the MMWAVEPOEEVM

Anonymous
Anonymous
Guru 17045 points
Part Number: MMWAVEPOEEVM
Other Parts Discussed in Thread: MSP-EXP432E401Y, UNIFLASH, MSP432E401Y

Tool/software: Code Composer Studio

Hi,

We have a brand new MMWAVEPOEEVM. We are trying to download a binary to it, more precisely the tcpecho for the MSP-EXP432E401Y. The reason of reusing this code is because we have not found an SDK specific for this MMWAVEPOEEVM so if there's any, please let us know. Then, we are aware that the target set during building may be very well wrong.

First experiment was to use CCS in debug mode. We set the jumpers to power the board from XDS3V3 and VCC3V3. No Ethernet cable is connected during flashing and POE is de-enabled (jumpers J6 and J7 are removed). 

XDS probe is recognized and the tcpecho is run. We connect the MMWAVEPOEEVM to a non-POE switch socket and no Ethernet traffic (LEDs) is present.

Second experiment was to set the jumpers to power the board from POE3V3 and VCC3V3. POE is enabled (jumpers J6 and J7 are in position) and the board connected to a POE switch socket. We launch UniFlash and set the device to be the MSP-EXP432E401Y. We tried also with MSP432E401Y. We tried to flash the board using the generated .out and .bin files out of the tcpecho project. The MSP432 seems to enter shutdown mode for both images and we have to unlock it back.

We have played with the Power Policy that comes by default in the tcpecho (de-enabling it), and no differences at all.

Could you please tell us:

  1. How to download a binary file to the MMWAVEPOEEVM? The procedure in the manual seems not to work in our case or we are mixing/missing concepts.
  2. More precisely, how to avoid power shutdown of the MSP432 when using the tcpecho demo.

Thanks in advance.

Best regards,

Mario

  • Hi Mario,

    Our POE Expert is currently away, we should have an answer for you sometime next week.

    Cheers,

    Akash

  • Anonymous
    0 Anonymous in reply to Akash Gondalia

    Update:

    We managed to flash using UniFlash by lowering TCLK. However, the tcpecho is not working as expected, since we do not see Ethernet traffic, most likely because the stack is not being brought up (the MSP enters some shutdown mode?):

    Service Status: DHCPC    : Failed   :          : 000
    

    The flashing is done powering the board from USB and removing the jumpers of POE of the MMWAVEPOEEVM. We checked that powering the board from POE led to the same results. 

    We moved to debugging in CCS. The board is unlocked to factory defaults and we actually see good Ethernet 10/100M connectivity. We de-enable POE. However, on clicking the bug, the LED is switched off so seems like the reset of the XDS110 probe introduces some shutdown on the Ethernet module. I've tried the risky option of commenting line 

    SysCtlPeripheralPowerOff(SYSCTL_PERIPH_EMAC0);

    in PowerMSP432E4.c but with no success.

    So TI guys, if you could give us some insights on these findings please, we would appreaciate it.

    Best regards,

    Mario

  • Hello Mario,

    Have you programmed the MAC address? 

    • MAC Address The boards ship with MAC address un-programmed. TI doesn't assign MAC address for this, but customer can use Uniflash to program their own MAC address.

    Amanda

  • Anonymous
    0 Anonymous in reply to AmandaN

    Hi Amanda,

    Indeed that solved the issue. The MSP-EXP432E401Y was shipped with a built-in MAC while the latest MMWAVEPOEEVM did not. 

    Thanks for your hint.

    Regards

    Mario