This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BOOSTXL-TUSS4470: TUSS4470 not detected by EVM GUI - "Hardware Disconnected"

Part Number: BOOSTXL-TUSS4470
Other Parts Discussed in Thread: USB2ANY, TUSS4470, MSP-EXP430F5529LP, UNIFLASH

I have new BOOSTXL-TUSS4470 and MSP-EXP430F5529LP evalutaion boards from TI and followed the setup instructions provided in the 'TUSS44x0 EVM for Ultrasonic Sensors User's Guide' (SLAU822A) section 2, 'Setup and Operation'. I have not made any changes to the hardware since receiving the boards and the jumpers have not been changed.  The TUSS4470 is set to USB Only mode. After connecting the EXP430F5529 + TUSS4470 boards to the computer with the provided USB cable, the TUSS4xx0 EVM GUI version 1.0.0.6 displays 'Hardware Disconnected' and a Red circle in the bottom left hand corner of the window.  I was able to run the MSP-EXP430F5529LP flash program as recommended by the TUSS4xx0 EVM GUI.  After this, I tried the same steps in section 2 of the user's guide (SLAU822A) on another Windows 7 computer with the same results. I noticed in Windows 7 Device Manager (under 'Other Devices') on both computers, there is an alert/exclamation with a device labeled 'USB2ANY/OneDemo device'. The user's guide (SLAU822A) references USB2ANY in section 3, so I looked for drivers for this device on TI website but instead found the application USB2ANY explorer 2.8.2.0. I downloaded opened it. This is displayed:

ERROR No USB2ANY controller was found.
ERROR Open failed -Error -24: Invalid handle

Two green LEDs are lit up on each board, matching the appearance shown in the user's guide (SLAU822A) on page 5, Figure 3.  I did try two separate USB cables on two different computers. Both computers are using .NET versions above 4.5 : 4.8 and 4.61.  I tried to install .NET 4.5 but It failed with the message, "Same or higher version of .NET Framework 4.5 has already been installed on this computer". I tried each cable with multiple ports on each computer, but the EVM GUI is unchanged, reporting "Hardware Disconnected" and Device Manager shows the same alert as before (USB2ANY/OneDemo).  Is there anyone on this forum with the same issue?  Thanks,  

John

  • Hi John,

    Since your OS in Win7, it is likely that the MSP430 and CCS drivers did not fully install in the background during the GUI install.

    You can manually install these driver's by navigating to "C:\Users\(USER_NAME)\Documents\Texas Instruments\TUSS Generation III\TUSS44x0\UNIFLASH" and run the "one_time_setup.bat" file as an administrator.

    If these drivers were already successfully installed, it may be the lack of the serial device driver for the MSP430. The GUI uses a serial COM port to connect to the MSP430F5529LP hardware. I have attached the "MSP430_CDC.inf" serial device driver file as follows: MSP430_CDC.inf

    On a host PC with older operating systems (i.e. MS Win 7 or older) it may be required that this device driver is installed.

    You can find this file and additional supporting driver files in the "MSP430_USB_Serial_Driver.zip" in the GUI install directory at: "C:\Program Files (x86)\Texas Instruments\TUSSGenIIIEVMGUI\TUSSGenIIIEVMGUI-1.0.0.6".

  • Hi Akeem, 

        I just installed the serial device driver by unzipping the three files inside the "MSP430_USB_Serial_Driver.zip" file you described. I was able to use the inf file that was already inside the zip file, called "msp430_ti_signed.inf" by right clicking on the file in Windows Explorer and selecting "Install".   The TUSS4470 is now detected by the EVM GUI and seems to be working. I don't see the procedure for this serial driver installation in the user guides.  Thank you for you help and providing these important extra details.

    John