This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LDC1614EVM: Connecting and Firmware Upgrade

Part Number: LDC1614EVM
Other Parts Discussed in Thread: LDC1614,

I have purchased two LDC1614EVMs.Both EVMs react in a like manner.

I'm using Windows 10 (64-bit) and have installed Sensing Solutions EVM GUI that was downloaded from TI site. Upon connecting the EVM to Windows, the GUI displays "Not connected" and "Ready". However nothing is displayed in the app window except Introduction. I've tried to accomplish a Firmware Upgrade with the provided "LDC1614_RevB.txt file. I am running the app as "Administrator." The result is that the upgrade shows no completion activity.

Windows' Ports shows Communication Port (COM1). There is some confusion as to HID devices (possibly older versions). For completeness, this devices show as "HID-compliant vendor-defined device" and four "USB Input Device."

I have attempted to find solutions on the Web and e2e, but nothing has worked. Apparently, others have had a similar experience, but I am unable to find the solution in e2e.

Any suggestions?

  • Forgot to mention that I have placed the EVM in BSL Mode by hardware PUR.

  • Hello,

    Please ensure that all steps in section 2.9 of the User's Guide are completed. It is not needed to put the EVM in BSL mode to flash the firmware. Launch the software and make sure no EVM boards are connected. Then, connect the EVM and upload the corresponding firmware file. If this firmware update fails, disconnect the EVM and restart the GUI.

    Best regards,


  • Nicole, Thank you for the response.

    Absolutely certain that Sec 2.9 was followed, but no joy. The GUI never finishes. See attached screenshot PDF.

    LDC1614EVM FW Upgrade.pdf

  • Hello,

    I was able to recreate the issue you are seeing. It seems that the GUI is unable to re-flash firmware to the LDC1614EVM while the device is in BSL mode. When this is happening, the firmware upload never completes.

    To resolve this, please complete the following steps:

    • Download the following MSP430 firmware upgrade example:

    • Connect the LDC1614EVM
    • Run Python_Firmware_UpgraderGUI.exe
    • If the device is connected and in BSL mode the screen should display "ready..."


    If this is not the case, ensure that the device is in BSL mode (no LEDs will be on) and click File -> Rescan HID Bus

    • Choose File -> Open User Firmware and navigate to the LDC1614_RevB.txt firmware file
    • When successfully completed the screen should read "Programming: OK"


    At this point, the LDC1614EVM should be recognized by the Sensing Solutions GUI and connect properly.

    Best regards,


  • Thanks again Nicole,

    Tried your suggestion: Downloaded Python Firmware Upgrader, got the Ready, and then got the HID Error..

    Opening HID device HID device (vID=0x2047, pID=0x0200, v=0x0109); Unknown manufacturer; @input.inf,%hid_device_vendor_defined_range%;HID-compliant vendor-defined device, Path: \\?\hid#vid_2047&pid_0200#8&17d525ba&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
    Exception in Tkinter callback
    Traceback (most recent call last):
    File "C:\msp430usb\msp430_usb\imports\MSP430USBDevelopersPackage_5_00_01\Host_USB_Software\Python_Firmware_Upgrader\build\pyi.win32\Python_Firmware_UpgraderGUI\out00-PYZ.pyz\Tkinter", line 1470, in __call__
    File "<string>", line 278, in selectFile
    File "<string>", line 185, in doLoad
    File "<string>", line 210, in open_connection
    File "C:\msp430usb\msp430_usb\imports\MSP430USBDevelopersPackage_5_00_01\Host_USB_Software\Python_Firmware_Upgrader\build\pyi.win32\Python_Firmware_UpgraderGUI\out00-PYZ.pyz\msp430.bsl5.hid_1", line 113, in open
    File "C:\msp430usb\msp430_usb\imports\MSP430USBDevelopersPackage_5_00_01\Host_USB_Software\Python_Firmware_Upgrader\build\pyi.win32\Python_Firmware_UpgraderGUI\out00-PYZ.pyz\pywinusb.hid.core", line 409, in open
    HIDError: Failure to get HID pre parsed data

  • Hello,

    Can you confirm that you are uploading the following firmware file?


    Best regards,


  • Hi Nicole, Good to hear from you again!

    I've been using the Rev B file that is part of the Sensing Solutions download. To be certain, I downloaded the file you specified. (They seem to be the same). However, I got the same error result when using the file you specified. Ready for your next idea. It's a mystery.

    I'm would like to use the EVM for an app that I'm developing. I'm designing my own inductor coils and would like to try my inductors out with the EVM.

  • Hi,

    Please ensure that the EVM is connected to a full speed USB port (USB 1.0 or above). It may be possible that the build is failing due to insufficient power.

    Best regards,


  • Hello Nicole,

    Moved the USB connection to a different powered USB 2.0 hub. Got the same results. At least this is consistent.

    Unless you have other suggestions, I will now build my own project board to test my own-designed inductor coils for my application. I was hoping to use the EVMs for this purpose, but this does not seem possible..

    I do not know if the problem(s) encountered is within my system, the Software Tools, or the EVM hardware.

    I am offering to send the EVMs to you for your evaluation. Certainly, I would be interested in the results. This may aid myself and others in the future.

    Thank you for your efforts.

  • Hello,

    I apologize for the issues you are having. One of the only other things I can think of to recommend is to confirm that the EVM driver is installed. This is supposed to happen automatically but may have been blocked by your PC during installation of the GUI. However, you had previously mentioned that it was showing up correctly in the device manager.

    If needed, a copy of the correct driver is located in C:\ti\Sensing Solutions EVM GUI-1.10.0\EVM Driver

    Best regards,