This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

SPIO-4: Can't read ph or temperature from LMP91200EVAL Board

Prodigy 80 points

Replies: 14

Views: 1144

Part Number: SPIO-4

I am currently using the LMP91200 v1.0.6.1 software on Windows 10, and have the LMP91200EVAL board connected to the SPIO-4 board which is connected to my computer via USB. I am using a ph sensor from Accumet (Cat. #13-620-631), which is connected to the LMP91200EVAL board with the BNC connector to measure ph. There is also a stereo plug from the ph meter for temperature output which is not currently connected to the LMP91200EVAL board, so I am not expecting to be able to read the temperature with the current setup, just the ph.

When I run the software to measure ph I get the following error:

"Wait too long for the data, capture will stop. Possible Reason: Transfer size too large."

I get this error message when I have the following settings in the Measurement tab: Ph Measurement, Specified Temperature of 25.0 C, Display PH Value, and Run for 1 second.

If I run the software using the above settings except changing it to use the Measured Temperature I get the following error:

"Wait too long for the data, capture will stop. Possible Reason: Transfer size too small"

I am not sure if the error is being caused by my ph meter or the LMP91200EVAL board and SPIO-4 board. If the issue is not receiving a temperature reading from the ph meter, how would I go about connecting the temperature output to the LMP91200EVAL board? Or is there a better ph meter that is made to interface with these boards and the software? I looked on TI's website but could not find a ph meter to use with this.

  • In reply to dBrock:

    Dan,

    I see, thanks for the information. We will look into using stand alone mode with the EVM.

    Also one last question: Do you know if there are any Matlab drivers to use the SPIO-4 Board with Matlab?

    Thanks for your help,

    Jordan
  • In reply to dBrock:

    Dan,

    I see, thanks for the information. We will look into using stand alone mode to use the EVM.

    Also one last question: Are there any Matlab drivers to use the SPIO-4 with Matlab?

    Thanks for your help,

    Jordan
  • In reply to Jordan Rosenbohm:

    Hi Jordan,

    Not that I am aware of. Please post this question on E2E in the Precision Data Converter forum since they may be able to better answer this question.

    e2e.ti.com/.../

    Best Regards,

    Dan
  • In reply to dBrock:

    Will do, thanks for all your help Dan.

    Jordan

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.