This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

AWR2243: The AppImage form SDK3.7 and SDK3.8 can not running in Cascade Radar with AWR2243.

Intellectual 690 points

Replies: 20

Views: 1013

Part Number: AWR2243

I got a cascade radar with AWR1243, and the new cascade radar arrived today, I put the same AppImage in AWR2243, this is what happend: 

It seems that they can't running the same AppImage, what should I do?

Looking forward to your reply. Thanks a lot.

  • Hi,

    Radar-SDK or Vision-SDK currently doesn't support AWR2243 at the software level.

    You need to use different firmware image (xwr22xx_metaImage) from the mmWave DFP

    http://software-dl.ti.com/ra-processors/esd/MMWAVE-DFP-2G/latest/index_FDS.html

    And the firmware file type is changed from 4 (AWR1243) to 0 (AWR2243) which you need to change in the SDK code.

    C:\PROCESSOR_SDK_VISION_03_08_00_00\ti_components\drivers\pdk_01_10_04_05\packages\ti\drv\vps\src\devices\radar_ar12xx\src\bspdrv_ar12xxFmwPriv.c: retVal = Bsp_ar12xxFmwSectionDwld(BSP_AR12XX_SECTIONTYPE_META_IMAGE   0); /* pass the value zero instead */

    Regards,

    Jitendra

    ----------------------------------------------------------------------------------------------------------

    Please check TI mmWave FAQs before posting a new query

    OR

    Use your search engine to look for some similar threads as shown below:

    "site e2e.ti.com <Your query>"

    ----------------------------------------------------------------------------------------------------------

  • In reply to Jitendra Gupta:

    I tried to use mmWave Studio 2.1 to upgrade the firmware of 2243, but there was no XWR2243 option in it,I tried to click the Load button to download the firmware, and there is an error :

    Did I do anything wrong? Or is there another way to update the  xwr22xx_metaImage?

    Thanks a lot.

  • In reply to J G1:

    Hi,

    You need to download different mmWave Studio which supports AWR2243 and select <DFP>\firmware\xwr22xx_metaImage.bin file to load.

    http://www.ti.com/tool/MMWAVE-STUDIO (2nd GEN)

    Regards,

    Jitendra

    ----------------------------------------------------------------------------------------------------------

    Please check TI mmWave FAQs before posting a new query

    OR

    Use your search engine to look for some similar threads as shown below:

    "site e2e.ti.com <Your query>"

    ----------------------------------------------------------------------------------------------------------

  • In reply to Jitendra Gupta:

    I saw a mmWave studio -2g on TI's official website, but I could not download it. Could this support 2243?

    Regards,

  • In reply to J G1:

    2G meant for second generation of mmwave sensor : AWR2243.

    You need to raise a request to get the download link, as download is available only on request.

    Regards,

    Jitendra

    ----------------------------------------------------------------------------------------------------------

    Please check TI mmWave FAQs before posting a new query

    OR

    Use your search engine to look for some similar threads as shown below:

    "site e2e.ti.com <Your query>"

    ----------------------------------------------------------------------------------------------------------

  • In reply to Jitendra Gupta:

    I got the software today and updated the firmware of 2243 by running the script in mmwave_studio_03_00_00_07:

    And I changed the code as you said and got the new appimage. I found that using 'gmak-s' and' gmak-s appimage' didn't change the content of AppImage , so I used the 'gmak-s clean' command and recompiled the entire SDK, but still couldn't get the radar to start.

    I read the code and found that when the device was version 1.0, it didn't seem to go into the branch where the code had been modified.

    Did I do any of the steps wrong?

    Looking forward to your reply.

    Thank you very much.

  • In reply to J G1:

    Hello,

    Here is the code change I did to support AWR2243 with TDA vision-sdk application.

    \ti_components\drivers\pdk_01_10_02_07\packages\ti\drv\vps\src\devices\radar_ar12xx\src

    bspdrv_ar12xx.c:  ---->

        retVal = Bsp_ar12xxRadarDeviceOn();
    
        if ((retVal == BSP_SOK) && (downloadFirmware != 0U))
        {
            //gBspAr12xxObj.arDeviceRevision = Bsp_ar12xxGetDeviceRevision();
            gBspAr12xxObj.arDeviceRevision = 3U;
            /* Download the firmware and run it on the AR12XX device */
            retVal = Bsp_ar12xxFmwSpiDwld();

    bspdrv_ar12xxFmwPriv.c ---->

    #define AWR2243_DEV  1

    /* ES3.0 Meta Image */
    #ifdef AWR2243_DEV
    #include <xwr22xx_metaImage.h> /* place the header file at the same location ti_components\radar\mmwave_dfp_01_02_00_00\firmware\ directory */
    #else
    #include <xwr12xx_metaImage.h>
    #endif

    Int32 Bsp_ar12xxFmwSpiDwld(void)
    {
    Int32 retVal = BSP_SOK;
    UInt32 arDevRev = gBspAr12xxObj.arDeviceRevision;
    if((arDevRev == 1U) || (arDevRev == 2U))
    {
    retVal = Bsp_ar12xxFmwSectionDwld(BSP_AR12XX_SECTIONTYPE_MSS_BUILD);

    if (retVal == BSP_SOK)
    {
    retVal = Bsp_ar12xxFmwSectionDwld(BSP_AR12XX_SECTIONTYPE_BSS_BUILD);
    }
    if (retVal == BSP_SOK)
    {
    gBspAr12xxObj.radarInitCompleteFlag = 0U;
    rlDeviceConfigureAckTimeout(0U);
    retVal = Bsp_ar12xxFmwSectionDwld(BSP_AR12XX_SECTIONTYPE_CONFIG_INFO);
    }
    }
    else if(arDevRev == 3U)
    {
    retVal = Bsp_ar12xxFmwSectionDwld(0);
    }

     

     


    Regards,

    Jitendra

    ----------------------------------------------------------------------------------------------------------

    Please check TI mmWave FAQs before posting a new query

    OR

    Use your search engine to look for some similar threads as shown below:

    "site e2e.ti.com <Your query>"

    ----------------------------------------------------------------------------------------------------------

  • In reply to Jitendra Gupta:

    I changed the code as you said:

    but still got the same error:

    Is there anything else that needs to be modified?

    Thanks and Regards

    JG

  • In reply to J G1:

    Hi,

    Could you check the file download status? Please try to do stepping with CCS to file the point where it returns non-zero value. I feel that after file download step somewhere else it hit the error.

    Regards,

    Jitendra

    ----------------------------------------------------------------------------------------------------------

    Please check TI mmWave FAQs before posting a new query

    OR

    Use your search engine to look for some similar threads as shown below:

    "site e2e.ti.com <Your query>"

    ----------------------------------------------------------------------------------------------------------

  • In reply to Jitendra Gupta:

    Hi,

    Unfortunately, I don't have this for debugging right now:

    Could you please send me an SDK that can be used for 2243?

    My email is guojun@microbrain.com.cn,

    Thank you very much,

    JG

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.