IWR6843ISK-ODS: Can I get ADC raw data from DCA1000 and data from UART simultaneously?

Part Number: IWR6843ISK-ODS
Other Parts Discussed in Thread: UNIFLASH, AWR2243BOOST, AWR2243

Hi, I have a IWR6843ISK-ODS and DCA1000 kit.

I'm running a overhead_mount_occupancy in https://dev.ti.com/tirex/explore/node?node=ALRSW97rqR7Y.z46NeSpEQ__AocYeEd__LATEST

What I want is to get raw ADC data and the result (or any other intermediate values I made) from the toolbox simultaneously

I can get raw ADC data by using DCA1000 and mmWave studio and also can get the result from UART respectively.

But I do not know how to get these in the same time

Could you let me know how to do?

Jaeyoon

  • Hello Jaeyoon,

    mmWave studio will configure data capture for a certain number of frames, So the UART output will not work well with the visualizers usually used to view this data. Using the OOB demo, the UART data should still be output on the data line. I am not sure about the Overhead people counting binary but it should work as well.

    If you use mmWaveStudio to configure and run the demo for raw data capture, but open a TeraTerm portal (or other COM port analyzer) at the data COM port and correct baud rate, do you see any data coming through? You will have to save this UART data, parse it, and match it up with the DCA1000 collected data. Can you try this?

    Thanks,

    Jackson

  • Hello Jackson, Thanks for your answer first.

    I'm quite newbie user of Ti RF module

    So I want to rectify if I understand correctly

    For now, I tested overhaed_mount_occupancy (afterwards, I'll note it by OMO) by flashing the prebuilt binary file into my board and set the SOP mode to functional mode, run overhead_vod_visualizer.m in gui directory. I checked I can get a point cloud and heatmap from data port.

    In addition to that, I checked I can get a raw ADC data(*.bin file) by 1)combining DCA1000 and RF board, 2)setting the SOP mode to development mode and 3)configuring and running mmWaveStudio

    I tried to open a TeraTerm and set UART data port connection while running mmWaveStudio and found that something comes through. But it looks quite different from something that I got when I run OMO through TeraTerm.

    So question is that will it be okay if I flash the OMO binary file to the board using uniFLASH and then get a raw ADC data as I mentioned above and save the UART data from data port in the same time and then parse this saved UART data as shown in the overhead_vod_visualizer.m in gui directory??

    Thanks in advance

    Jaeyoon

  • Hello Jaeyoon,

    Please give me a little more time to look into this. It would help me if you could give more details on what you are trying to understand from the raw data vs. the UART data? More information can be viewed by the Demo Visualizer on ti.com. This will only work with the OOB demo binary, not the overhead people counter that runs the tracker, but the pointcloud response can be configured to be similar.

    Regards,

    Jackson

  • Hi Jackson

    Actually I want to advance the algorithm of overhead counter and then put it into the TI board. In the development phase, I need raw data and some already processed data such as range-azimuth heatmap and they should be synced. So it is not enough to just view plots in Demo visualizer.

  • If you need the RAheatmap as a UART output, you will need to use the OOB demo firmware and configure it for that. UART + LVDS output should work for OOB, have you tried that combination? This will not have tracking output but will show you raw data + pointcloud and any other output configured by OOB output.

    Regards,

    Jackson

  • "UART + LVDS output should work for OOB, have you tried that combination?"

    As an answer for this mention, what I did is as following

    1) I fixed the code to simplify
    - I removed almost all codes to be performed during inter-frame (like Capon BF Doppler Estimation). Instead the code just send a fixed string through mailbox from DSS to MSS

    - MSS then accept this message from mailbox and send this script through UART (Because I do not want to parse the UART result instead just want to show the message in TeraTerm)

    2) Checked if UART shows the same string at every frame when I run the binary in functional mode after pushing the binary into the board using UniFlash

    3) Tried to use mmWaveStudio to get LVDS output letting the board in development mode(no action except changing SOP jumper was taken to the board after step 2). I used the same config file. Then, I triggered the frame but the result in the TeraTerm is not same as the message. (As far as I know, using mmWaveStudio is the recommended option to get LVDS data) 

    I think your answer indicates that in step 3, I must get the same data as the step 2. Is there anything wrong in what I did? or Isn't this third step procedure what you are going to say?

    Thanks

    Jaeyoon

    P.S. - actually I'm confused. When I set functional mode, the bootloader in the board automatically load and run the binary firmware, but does it either in development mode? - cause I must set to be development mode to run mmWaveStudio

  • Hello Jaeyoon,

    Did you load the same firmware in mmWave studio as you did in uniflash? I don't think the issue should be so much with what is transferred from DSS->MSS, but what is output by the MSS on UART. What was the intended output on UART and how did it change?

    Yes we do use mmWave studio to save the LVDS data.

    Regards,

    Jackson

  • Hi Jackson

    I think I was not loading the same firmware. I just loaded the default firmware ( C:\\ti\\mmwave_studio_02_01_01_00\rf_eval_firmware 1) \masterss\xwr68xx_masterss.bin for MSS FW and 2) \raderss\xwr68xx_radarss.bin for BSS FW).

    Then there is another question (sorry for bothering you, I'm quite newcomer on Ti)

    When I build the project using Code Composer Studio (CCS) I get metaImage file (which contains MSS, DSS and BSS FW in). Then how can I load this metaImage in mmWaveStudio? cause there are only two options in mmWaveStudio, one for BSS FW and the other for MSS FW not for meta Image file

    I followed https://e2e.ti.com/support/sensors/f/sensors-forum/885077/awr2243boost-warmrst-and-cannot-connect-to-rs232/3288357#3288357 -"If you are using AWR2243 with DCA1000 then you need to have only one jumper on AWR2243BOOST (SOP-0 jumper) and then in the studio follow these steps to configure the device.

    1. Click Reset button in Connection TAB (board control). It should toggle the yellow LED of AWR2243BOOST.

    2. Directly jump to device connection (without RS232 connection) by pressing 'SPI Connect'. - <truncated next>"

    But failed to connect SPI connection in step 2

    Regards

    Jaeyoon

  • HI, Jaeyoon:

    Let us come back to your original goal.   As you said, you can use radar studio + DCA1000 for raw data capture; or you can run people counting demo code to get point cloud results.  But there is no binary that allow you to get raw ADC data as well as get people counting demo results.  Although the SDK out-of-box (OOB) demo can do raw data capture and point cloud output together, OOB demo uses a completely different signal chain and its results will not be helpful for you to evaluate people counting demo.  

    As a summery, we do not have a solution to capture raw ADC data and people counting demo output at the same time on the same board.   

    Best,

    Zigang

  • Hi Yang

    I think the word "counting demo" make you confused

    Yet, what I want is counting demo, it does not matter if this is for counting demo or whatever

    I think the core is how to get ADC data and UART data simultaneously using mmWaveStudio as Jackson mentioned it would be possible.

    I tried but failed to load the firmware (it does not matter if it is for counting or whatever). I think if I success to load the meta Image firmware then this issue will be addressed. (Sorry for bothering  yes I didn't load the same firmware but I failed to)

    To sum up, I has Meta image firmware and dss, mss firmware but no BSS firmware and mmwave studio seems to require to load BSS and MSS firmware. After some googling, someone said that after flash the metaImage using UniFlash and set the board to be functional mode(SOP:4) and click SPI connect without loading firmware but it fails to connect SPI connection when I tried.

    Is there any solution?

    Thanks

    Jaeyoon