This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CCS/MSP-EXP432P401R: CCS Build error V9.1

Prodigy 160 points

Replies: 2

Views: 65

Part Number: MSP-EXP432P401R

Tool/software: Code Composer Studio

I am using CCS V9.1 for building DSP project. I am using OMAP-L138 processor.

In CCS V5.3 my DSP project is working fine and I am able create out file but in updated version I cant able to build it. So kindly help in this issue.

Error message is attached 

Thanks,

Prashant

  • below is the build output:


    **** Clean-only build of configuration Release for project readwrite_M3_10Nov ****

    "C:\\ti\\ccs910\\ccs\\utils\\bin\\gmake" -k clean

    DEL /F "MTL32_2020_108P.hex" "MTL32_2020_108P.out"
    DEL /F "AD_2020_001.obj" "Cmd_2020_001.obj" "DAQ_2020_001.obj" "DGSC_2020_001.obj" "EDMA_BiSSDriver_UACE2020.obj" "Esc_2020_001.obj" "ISR_2020_001.obj" "ISR_fpga.obj" "ISR_timer.obj" "Main_2020_001.obj" "Main_timer.obj" "Ports_2020_001.obj" "Servo_2020_001.obj" "Timer_MK3_001.obj" "Wave_2020_001.obj" "tskReadwrite.obj" "edma\edma.obj" "edma\edma_mod.obj" "edma\uart.obj" "edma\uartConsole.obj" "edma\uartStdio.obj" "ledgpio\gpio.obj" "ledgpio\ledgpio.obj" "ledgpio\psc.obj" "task\readwrite_config.obj" "timer\Timer.obj" "timer\Vectors_timer.obj" "timer\interrupt.obj"
    DEL /F "AD_2020_001.d" "Cmd_2020_001.d" "DAQ_2020_001.d" "DGSC_2020_001.d" "EDMA_BiSSDriver_UACE2020.d" "Esc_2020_001.d" "ISR_2020_001.d" "ISR_fpga.d" "ISR_timer.d" "Main_2020_001.d" "Main_timer.d" "Ports_2020_001.d" "Servo_2020_001.d" "Wave_2020_001.d" "tskReadwrite.d" "edma\edma.d" "edma\edma_mod.d" "edma\uart.d" "edma\uartConsole.d" "edma\uartStdio.d" "ledgpio\gpio.d" "ledgpio\ledgpio.d" "ledgpio\psc.d" "task\readwrite_config.d" "timer\Timer.d" "timer\interrupt.d"
    DEL /F "Timer_MK3_001.d" "timer\Vectors_timer.d"
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\MTL32_2020_108P.hex
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\AD_2020_001.obj
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\edma\edma.obj
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\ledgpio\gpio.obj
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\task\readwrite_config.obj
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\timer\Timer.obj
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\AD_2020_001.d
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\edma\edma.d
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\ledgpio\gpio.d
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\task\readwrite_config.d
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\timer\Timer.d
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\Timer_MK3_001.d
    Could Not Find C:\MTL32_2020Code\OMAP\MTL32_2020_108P\MTL32_2020_001\Release\timer\Vectors_timer.d
    Finished clean

    **** Build Finished ****
    Buildfile generation error occurred..
    This project was created using a version of DSP/BIOS tools that is not currently installed: 5.42.0.07. Please install the DSP/BIOS tools of this version, or migrate the project to one of the supported versions.
    Build stopped..

  • Guru 166850 points

    In reply to prashant sharana:

    The messages about "Could Not Find" files is happening during the Clean step and is just a notification that it could not find those files to delete. That is ok to ignore.

    The second error is more important. As the message says you need to install version 5.42.0.07 of DSP/BIOS into CCSv9. Please refer to this document for information on how to do it. http://software-dl.ti.com/ccs/esd/documents/ccs_product-installation-selection.html

    I presume you already have that version of DSP/BIOS installed in your system since you are using it with CCS 5.3. If so, you can simply point to its location from CCSv9 to have it discover it.

    Hope this helps.

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Explore Code Composer Studio documentation and resources using online Resource Explorer
    Track a known bug with SDOWP. Enter the bug id in the "Find Record ID" box

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.