This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CCS v5 could not open source file "bsp_board_defs.h"

I just installed the lastest version of CCSv5 (M6), and trying out the Wireless Sensor Monitor sample application for the eZ430-RF2500 (MSP430)

I'm getting these two errors:

code composer studio v5 could not open source file "bsp_board_defs.h"

code composer studio v5 could not open source file "bsp.h"

 

And I don't understand why.

Could you help? Shall I provide more information?

 

Many thanks

  • Hello,

    CCS can't find the location of those files. You will need to add it to your include search path options of your project Build Properties. Do a search for those files on your PC and then add the directory where those files are located to your include search paths.

    Hope this helps

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • Guru 131180 points

    In reply to Ki-Soo Lee:

    Hi,

    Just adding to Ki's reply, I imported the ez430-RF2500_WSM project into CCSv5.1 M6 and, despite a warning about an invalid path (harmless since the same path is already included), the project built fine. Check the screen attached.

    When importing this project, make sure to uncheck the option Copy projects into workspace. That will prevent from breaking any linked references.

    Hope this helps,

    Rafael


    When posting, click on the link Insert Code, Attach Files and more... to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "This resolved my issue".

  • In reply to desouza:

    desouza

    When importing this project, make sure to uncheck the option Copy projects into workspace. That will prevent from breaking any linked references.

    Thanks for the responses. Copying the project into the workspace was indeed breaking linked references, unticking that option fixed the problem!

    Many thanks again,

    Davide

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.