This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

Error initializing emulator

Genius 3155 points

Replies: 4

Views: 4538

Hi,

I'm not able to get CCS3.3 to connect to the XDS510 USB emulator (see error message below). I was using the same setup on my older PC no problem.

I ran SDConfigEx.exe from spectrum digital and it was able to detect the XDS510!

Any ideas?

khaled.

Error initializing emulator
I/O Port = 510
Board Name: TCI6486_XDS510USB
Cpu Name: IcePick

Abort:        Close Code Composer Studio.
Retry:        Try to initialize the emulator again.
Ignore:        Ignore the initialization error and start
        potentially without target debugging access.
Diagnostic:    Run diagnostic utility.

  • Found the problem :-)

    I forgot to setup a custom board configuration i.e. add a bypass (4).

    thanks.

    khaled.

  • Hi,

    I have problem regarding to connection setup between CCS v3.3 and XDS510-USB2.0 Emulator .

    Error is as following:

    Error initializing emulator

    I/O Port = 510

    Board Name: F2407 XDS510 Emulator
    Cpu Name: CPU_1

    Abort: Close Code Composer Studio.
    Retry: Try to initialize the emulator again.
    Ignore: Ignore the initialization error and start
    potentially without target debugging access.
    Diagnostic: Run diagnostic utility.

    Please help me

  • Guru 301290 points

    In reply to Nauman Asghar:

    Hello,

    Are you also using a Spectrum Emulator? If so, I suggest running the SDConfig tool like Khaled did and see if all the tests pass. If you are using some other emulator brand, use whatever diagnostics tools they provide. 

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training/Documentation? Check out the CCS Resources page

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki:

    Hi, 

    I run SDConfig tool for testing. it seems it can't pass any test. i ma using XDS510-USB2.0 TI DSP Emulator. when i connect usb to computer, it instals black hawk jtag

    driver.  i have attached a snap shoot with this post. 

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.