This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS5: Error -1003 @ 0x2BC5, also Java heap size error

Prodigy 160 points

Replies: 4

Views: 1580

CCS constantly returning this error message when entering debug mode on a M35H52C1:

Cortex_M3_0: Error during Flash programming (Flash algorithm returned error code). Operation cancelled.

Cortex_M3_0: GEL: File: C:\TIDCS\AV-900 Upgrade\DC Controller\TI Concerto\M3 ARM\Flash\M3_ARM.out: Load failed.

Cortex_M3_0: Unable to terminate memory download: (Error -1003 @ 0x2BC5) Internal error: Invalid parameter passed to function. Restart the application. If error persists, please report the error. (Emulation package 5.0.872.0)

Also Java heap size error came up first that was totally bogus, as no size increase size helped. Reinstalltion didn;t help either, until I uninstalled and installed clean...

Thanks,

Mason

4 Replies

  • Guru 173300 points

    Mason

    CCS constantly returning this error message when entering debug mode on a M35H52C1:

    Cortex_M3_0: Error during Flash programming (Flash algorithm returned error code). Operation cancelled.

    Cortex_M3_0: GEL: File: C:\TIDCS\AV-900 Upgrade\DC Controller\TI Concerto\M3 ARM\Flash\M3_ARM.out: Load failed.

    Cortex_M3_0: Unable to terminate memory download: (Error -1003 @ 0x2BC5) Internal error: Invalid parameter passed to function. Restart the application. If error persists, please report the error. (Emulation package 5.0.872.0)

    Which exact version of CCS are you using - is it the latest 5.3? Is the target board the TI Concerto controlcard/kit or a custom board?

    Does the error occur when loading other programs as well or is it specific to this one program? If the error occurs with other programs as well it could point to a device issue.

    You could also try programming the code using UniFlash and see if that helps? Another user was able to get around this error using UniFlash - please see this thread.

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Explore Code Composer Studio documentation and resources using online Resource Explorer
    Track the status of a known bug in the External Bug Tracking System. Visit this FAQ to learn how to search for a bug.

  • In reply to AartiG:

    Hi AartiG,

    I'm using the latest version and the target is a custom board, however it's been verified to work fine with pretty much every peripheral now.

    The problem occurred with other programs as well. It was definitely related to the CCS and its compatibility with latest Java updates perhaps, as it happened after a Java update and it started complaining about Eclipse heap size error as well.

    The heap size error was bogus as I said before. Reinstalling CCS didn't help either and it was still complaining about the heap size until I unistalled the CCS and reinstalled it from scratch. Now everything is up and running.

    The whole point of my post was to notify the CCS team of a potential Eclipse issue with Java VM updates and perhaps setting the heap size per the user machine memory size instead of just using constant small values for all machines.

    Thanks,

    Mason

  • Guru 173300 points

    In reply to Mason:

    Thanks for the update and clarification. I will pass your observations and feedback on to the CCS development team. And I take it then that CCS is working fine since the uninstall and clean reinstall. Could you please confirm that both the java heap error and flash programming errors were resolved after the clean uninstall/reinstall?

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Explore Code Composer Studio documentation and resources using online Resource Explorer
    Track the status of a known bug in the External Bug Tracking System. Visit this FAQ to learn how to search for a bug.

  • In reply to AartiG:

    Thanks, AartiG. The CCS is working fine now.

    Mason

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.