This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

CCS: GUI Flickers on mouse Movement after web content was shown

Prodigy 80 points

Replies: 4

Views: 339

Tool/software: Code Composer Studio

Hello,

I'm experiencing enormous flickering when of the UI in CCS Version: 9.2.0.00013 on Linux, Ubuntu 18.04 LTS with KDE as DE.
The UI flickers rapidly when the mouse cursor in moved, and in about 1 Hz when the mouse cursor stays still.

It happens when I open the ROV or the Resource Explorer. In the resource explorer less quickly, in the ROV usually after clicking 1-3 elements.

The ROV or Resource explorer don't flicker, but the rest of the UI does.

If you need any more details, let me know.

  • Guru 318515 points

    Hello Johannes,

    Can you try the below workaround:

    Open a terminal and type:

    > export SWT_GTK3

    then (in the terminal), browse to <CCS9 INSTALL DIR>/ccs/eclipse and run ./ccstudio

    Check to see if the issue still exists or not.

    Thanks

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training/Documentation? Check out the CCS Resources page

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • Guru 318515 points

    In reply to Ki:

    Hello Johannes,

    Just following up with you to see if you had a chance to try the proposed workaround

    Thanks

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training/Documentation? Check out the CCS Resources page

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

  • In reply to Ki:

    Hi Ki,

    with setting eclipse to use GTK3, the ROV seems to work normally and does not introduce flickering anymore. The Resource explorer on the other hand still makes the GUI flicker.

    But having the ROV working already helps me a lot. I can open the resource explorer in the browser as well.

    Thank you very much already!

    Regards,

    Johannes

  • Guru 318515 points

    In reply to Johannes Wechsler:

    Actually, I meant to say:

    > export SWT_GTK3=0

    I forgot the part about explicitly setting it to 0. But I think both ways do the same thing. At least that is the behavior I see.

    I'm not sure why the workaround works for ROV but not ReX. It should apply to both.

    I filed a bug for the flicker issue. Tracking ID: CCDSK-3753

    Thanks

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training/Documentation? Check out the CCS Resources page

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

    NOTE: When a bug is filed and a tracking ID is provided, the thread may then be suggested as "TI Thinks Resolved". Why? Please read the first FAQ of the CCS Forum Guidelines & FAQ

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.