This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-F280049C Not Connecting to TI Cloud Agent

Other Parts Discussed in Thread: LAUNCHXL-F280049C, TMS320F280049C


My customer is trying to use the LAUNCHXL-F280049C board with a TI Cloud GUI. The board is detected by, however when launching the GUI the following error occurs:

COM3:115200 Error configuring Debug Server: error=Failed to connect to TMS320F280049C device: Please unplug your hardware, then plug it back in and try again

Unplugging and replugging does nothing. Restarting the computer does nothing. Changing to a different USB port does nothing. Reinstalling TI Cloud Agent does nothing. Trying a different browser (Firefox instead of Chrome) does nothing.

We enabled the log, however no log is creating when launching the GUI and seeing this error. The log is created properly when detecting the board on

Matthew Guibord

  • Matt,

    When you say you get this when launching the GUI what do you mean?  Are you running a GUI demo from the Gallery or importing a project from Resource Explorer into to CCS Cloud?  Are you running the project wizard on  If you are using an example can you let me know which one so I can give it a try.



  • Hi John,

    This is a GUI being launched from the Gallery called "Contactor_Driver_BoosterPack_GUI" version 1.0.1.

    I am able to run the board and GUI from my computer, but I also saw this error early in my attempts. It randomly went away, but the customer has not been so lucky.

    Matt Guibord

  • Matt,

    I have a F280049C LaunchPad but I don't have this boosterpack so I can't do much with the GUI.

    If I take a look at the app it looks like it uses the onboard XDS110 to flash a specific image and then uses a serial connection for communication between the target program and the GUI afterwards.

    I was able to connect ok.  Only trick was setting the serial port correctly.

    I did manage to get the same error as them, however to do that I had to plug in a completely different non-C2000 LaunchPad.  If I do that then I get

    Could they have more than one LaunchPad plugged in?

    Are they able to import an F280049C example into CCS Cloud and load that ok?  That would be one thing to test to see if the debug agent is installed correctly.

    Here is what they could do to test that. It is a bit tricky as most of the examples are setup for the controlCARD which has an XDS100 instead of an XDS110 like on the LaunchPad.

    1) on click on the button to create a project online

    Hopefully it detects the board ok

    After clicking Next.  Type LED in the filter box at the top right and then select the first example listed.  led_ex1_blinky

    Click the import button on the right to import this project into CCS Cloud

    Expand the targetConfigs folder and open both of the files.  Then copy the contents of the TMS320F280049C_LaunchPad.ccxml file and paste it in the TMS320F280049C.ccxml file.  

    We have to do that as the example is setup to use the controlCARD with the XDS100 and the LaunchPad has the XDS110.

    Once that is done save the file and then click on Debug.  

    Does the debug session launch correctly?

    If so then the connection to the board with the debug agent running is good.

    After that I would close CCS Cloud and try the GUI again.



  • Hi John,

    I was able to get this to work myself, but the customer was not. He received the following popup, similar to what was seen when using the GUI. 

    In addition, the following text showed up in the status log at the bottom:

    Matt Guibord

  • Hi Matt,

    Do you have CCS installed? If so, I'd like for you to run the JTAG connectivity test utility that comes with CCS:



  • Hi Ki,

    We tried connecting through CCS today and also had issues when trying to run the program. The "test connection" in the target config passed without issue though. I gave him my setup and it is working fine on his computer. We'll conclude this as a bad board, since it also fails on my computer. Thanks for the help.

    Matt Guibord