This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430G2353. Internal error while writing.

Other Parts Discussed in Thread: UNIFLASH, MSP430G2353, MSP-EXP430G2, MSP430G2231

Hello,

We are using MSP430G2353(custom board) & MSP-EXP430G2 launchpad for our project.  Uniflash Programmer to program the controller.

While Releasing the code we are not facing any problems, it works just fine. The problem arises when we try to program the controller using Uniflash (tried for both .out & .txt files).

We tried using MSP430 flasher also but no help there.

It is related to flash memory and since I am new to MSP430 programming I have no idea how to resolve that.

I have attached the image of that.

Any help would be greatly appreciated.

Thanks in advance.

YS

  • Moving to CCS forum for Uniflash support.

    Regards,
    JH

  • Are you able to download the program with Code Composer Studio ok? You mentioned that the code works ok so I am assuming that you were able to load it in CCS or another tool at some point.

    John
  • Hi John,

    Downloading using CCS6 ? No, we couldn't do that either.

    When we tried programming using CCS, we got an error pointing to some memory location, which when checked, pointed to Flash memory.

    We had tried this a few days back and didn't face any problem. Now all of a sudden its not working.

    I have attached the snapshot. Please check out.

    Thanks,

    YS

  • YS,

    Ok. So neither CCS or Uniflash can write the flash, that makes sense as they use the same components. Does this only occur with your custom board or does it happen with the G2553 LaunchPad as well? If it happens with the LaunchPad I have one here and could try loading the program and turning on logging.

    Regards,
    John
  • Hi John,

    Yes, the problem occurs only with this particular custom board. Launchpad works OK.
    We have another custom board (MSP430G2231) and the same launchpad was used. So there is no problem with the launchpad (I hope)..

    Regards,
    YS
  • Some common problems;

    Verify the SBWTDIO (/RST) pull-up resistor is not smaller than 4.7KOhm and the (ground) capacitor not greater than 2.2nF. If any doubt remove both, the JTAG doesn’t (like/) need them.
    If the Reset is provided from another source, be sure this is an ‘open-collector/drain’ type, is floating and from low capacitance.

    Don’t use long (>150mm) connection cables.