This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/MSP430G2210: Problem with programming and MSP-FET430UIF

Part Number: MSP430G2210
Other Parts Discussed in Thread: MSP-FET

Tool/software: Code Composer Studio

Hello everyone, and thanks in advance for all the support you provide on the forum.

I ran into a problem while programming with the MSP-FET430UIF on my CCS 5.

I started programming a couple months ago, and I could easily run the program and load it into my target microcontroller, the MSP430G2210.

However, when I open the same project on another PC and try to upload it on other units (still G2210s) I keep on getting errors.

The first problem I encounter is when I try to debug and the compiler tells me that the code contains a lot of errors (that were not present in the project on the other PC).

The second error message I get is "Error connecting to the target: Unknown device".

I tried looking for the solution online, and checked multiple times my Spy-bi-wire connection, making sure that I connected the right pins on the micro to the right pins on the MSP-FET and that I added the resistor and capacitors listed in the circuit on the guide to the JTAG connections.

While looking on this forum for some pieces of advice, I found out about the "target configuration" testing, and I tried it. As in the other cases, the compiler gives me a ton of errors, saying there's an overlap of memory.

I tried also going back to the old PC, but the same situation applies.

Is there a way I can solve my problems? I tried also reinstalling CCS, MSP430Ware, drivers and libraries, but nothing changed.

Thank you very much, really appreciate your help.


  • Hello Ivan,

    Ivan De Stefani said:
    However, when I open the same project on another PC and try to upload it on other units (still G2210s) I keep on getting errors.

    Does the other PC have the same version of CCS installed?

    Are the other G2210 the same revision as the one that works?

    Did you try using the G2210 that you have been using successfully on the other PC?



  • Hi Ki, thanks for your quick response.

    I checked the CCS version on both PCs and yes, they are the same.

    Unfortunately though, I cannot test the previous G2210 because we already shipped it to the customer.

    However, I had ordered a sample batch of G2210 for the first application, while the second batch came directly soldered on a PCB from a supplier.

    Is the revision number the one written on the micro casing under its model number "G2210"? Because those numbers are different, and I was thinking it might be a serial number of sort.

    Anyway, if it turns out to be a different revision, could you please tell me how I can solve my problem?

    Thank you very much

    Best Regards


  • Ivan,
    Can you try upgrading your CCS version? 5.5 is very old.