This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/TMS320C28343: Error during Debug mode due to emulator connection

Part Number: TMS320C28343

Tool/software: Code Composer Studio

I have updated the spectrum emulator driver when installing the CCS 6.2. 

When I debug the program the error message show like this :

Description Resource Path Location Type
File connections/SD510USB_Connection.xml does not exist. Was included by file C:/Users/Admin/workspace_v6_2/Example_2834xEPwm_ControlBoard_Test/XDS510USB.ccxml XDS510USB.ccxml /Example_2834xEPwm_ControlBoard_Test line 0 Problem

From previous thread, I already tried the following steps

1. check the SD510USB_Connection.xml file in  C:\ti\ccsv6\ccs_base\common\targetdb\connections

2. select the connection as : Spectrum Digital XDS510USB Emulator 

3. Verify the emulator connection the message shows connection is good like this: 

** Resetting Emulator
-- Emulator is Reset
** Emulator Scan Test
-- Found JTAG IR Length of 38
-- Found 1 device(s) in the scan chain


4. In the project, I include XDS510USB.xml which has the code like this: 

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<configurations XML_version="1.2" id="configurations_0">

<configuration XML_version="1.2" id="Spectrum Digital XDS510USB Emulator_0">
<instance XML_version="1.2" desc="Spectrum Digital XDS510USB Emulator_0" href="connections/SD510USB_Connection.xml" id="Spectrum Digital XDS510USB Emulator_0" xml="SD510USB_Connection.xml" xmlpath="connections"/>
<connection XML_version="1.2" id="Spectrum Digital XDS510USB Emulator_0">
<instance XML_version="1.2" href="drivers/sdgo28xusb.xml" id="drivers" xml="sdgo28xusb.xml" xmlpath="drivers"/>
<platform XML_version="1.2" id="platform_0">
<instance XML_version="1.2" desc="TMS320C28343_0" href="devices/c28343.xml" id="TMS320C28343_0" xml="c28343.xml" xmlpath="devices"/>

Thanks and Regards, 


  • Benny,

    When are you getting the error? During the launch of the debug session or when trying to connect to the core?

    I would suggest creating a new ccxml with XDS510 as the probe and TMS320C28343 as the device using View->Target Configurations. One you have created the ccxml, right click and select "Launch Selected Configuration".

  • Ben,

    Just adding to Mark's reply, check the following short clip for details on how to manually launch the debugger

  • Thanks Mark and Rafael

    it works now. I find another way to configure the ccxml file by double click on the XDS510USB.ccxml. I could enter the general setup for configuring the target MCU. 

    Another thing is that to run the Spectrum emulator, you need to have a full license for CCS.

    Here is some steps of how I setup the connection to the Spectrum XDS510 emulator:

    Configuration 1

    By double click on the XDS510USB.ccxml. you could enter the general setup for configuring the target MCU. 

    Select the target MCU, and verify the connection. 

    Configuration 2,

    Setup on the project properties, select the target MCU on Variant, and Emulator on Connection. 

    Configuration 3, Setup license

    Help -> Code Composer Studio Licensing Information

    Upgrade -> launch license setup -> activate