This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/TPS65917EVM: "MSP430: Error connecting to the target: Unknown device" when using an external debugger.

Part Number: TPS65917EVM
Other Parts Discussed in Thread: USB2ANY, MSP-FET430UIF, MSP-FET

Tool/software: Code Composer Studio

Hello,

I have a problem, and I almost tried everything, but zero succes.

So, I need to set up the TPS65917EVM's MSP430 to use SPI communication (partner order stuff), and I want to flash the USB2ANY fw for it.

I connected an MSP-FET430UIF external debugger interface to the EVM's JTAG (supply jumper is off), USB is connected either. 

The GUI recognizes the board, can be set up.

CSS identify the debugger finely.

BUT, when try to flash (debug) the MSP the next thing happens:

1.Building the code

2.After building is completed it start the debugger, and try to reach the board.

3.The FET's red led start to blink (blinking=comminucation -> in datasheet) like 2-3times

4.The EVM's reset LED lit.

5.Windows device disconnected sound (TUdum) happens.

6.CSS give error: MSP430: Error connecting to the target: Unknown device

7.After cancel the error windows device plugged in sound playing (tuDUM).

And thats it. No flasing, no debugging, board working fine either the SMPS's and the GUI. But can not be flashed.

Any ideas?

I tried to supply from JTAG, from USB, tried to disconnect or connect the regulator's supply, try to use only the JTAG, tried 2 different debuggers (FETs), tried to use different USB ports, tried to reinstall CSS completely, tried to use both debugger and LP5529 debugger version of the build (i know the LP is for lauchpad but who knows), tried to downgrade and upgrade the FW of the FET, etc.

Thanks in advence :)

Have a nice day,

-Szabi

  • Hello Szabi,

    I think I know what your issue here is. I took a look at the schematic for this EVM, and it seems the JTAG connection to the on board MSP430 is not quite correct. It is trying to use the SBW (2-wire JTAG) method, but it is not properly hooked up. It should follow the example that is given in Figure 2-3 within the MSP430 Hardware Tools User Guide () . Looking at the differences between the schematic and this figure, I see a few things wrong.

    • Pull-up resistor on RST line is too weak.
      • Change R10 to 47k ohm
    • Pins 2 and 4 on JTAG header are tied together
      • This will cause confusion to debugger as it tries to asses if the part is powered already or the MSP-FET needs to power the board. It seems the designer wanted to give that option. A proper way to do this is to have a 3 way jumper with board VCC in the middle. You could then jumper board VCC to the pin 4 if already powered, or connect pin 2 to board VCC if wanted the tool to power the board during debug.
    • RST/NMI/SBWTDIO should go to pin 1 on JTAG header for SBW (2-wire JTAG) mode
    • TEST/SBWTCK should go to pin 7 on JTAG header for SBW (2-wire JTAG) mode
      • These last two points is an easy mistake to make as Test and RST are used during 4-wire JTAG. It seems these are currently routed to the 4-wire JTAG spots.

    In order to program your device on htis board, I would suggest doing the proper routing/translation of pin via blue wire jumpers between the MSP-FET and the JTAG header.

  • Hey JH,

    Thank you for your answer :)

    So:

    -R10 pullup is 120kOhm atm. Should i really change it to 42k?

    -Pin2/4:

    As far as i understood (by other datasheets and stuff): Of course somebody needs to power to MSP. You can choose it to be the JTAG, or the MSP has it's own supply. It's theoritical shown at the picture you attached, but on the EVM it is different a bit.

    As you can see, the two pins are rally tied together, so (in my opinion) the JTAG (FET) supplies itself, and you can connect the jumper if you want to supply the MSP from here. If the Jumper is disconnected, the MSP need to be supplied from the USB. I tried both cases already, both supplies the MSP fine, (LEDs are showing etc), but none of them worked (while tried to flash).

    ***The SBWTCK shows DNP mark, but it is actually connected to the MSP's pin #71 on mid-4 layer***

    The last part you wrote that when 2pin sbw used pin1 and pin7 should be used. Is this true?

    I mean, should i re-wire the JTAG? I would give it a try with small cables (blue wire jumpers?) (connect the FET's pin1/7 to the EVM's pin8/11) and hope the best.

    I try this stuff out and write what will happen :)

    Thank you very much again, and have a great day.

  • Tried to connect with wires from FET's pin 1-7 to JTAG's pin 8-11. Same error: when try to reach the board, reset led lit, unable to connect (unknown device) etc.... :(
  • Heyho!!!!
    I treid some different connections with the wires, and actually a designer error was probably made.
    On the EVM's board the pin2-4 are connected internally, and that was causing the problem.
    As shown on the recommended 2wire SBW conenction, either the pin2 or pin4 should be connected to the 3.3V (with the help of jumper).
    Actually i connected the J34 jumper and plugged out the pin4 for hanging and it started to work like a charm.
    So there should be a 3 way jumper to select, but instead the 2 JTAG pins are connected internally which is not good, and should be terminated.
    The program loaded, so i can start to debug.

    Thank you very much for the help!!!!:)

    -Szabi
  • Szabi,

    I'm glad you were able to resolve the issue. The reason the 2-4 pin tie is bad form the debugger perspective, is that the debugger will try to place voltage on the pin 2 while at the same time it will check to see if voltage is on pin 4. If they are connected, the debugger will see itself and not function correctly.