This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/MSPWARE: CCSv8 on OSX doesn't find MSPWare after installing from Resource Explorer

Part Number: MSPWARE
Other Parts Discussed in Thread: MSP430WARE

Tool/software: Code Composer Studio

After installing MSPWare from the resource explorer in CCS in mac it installs by default to "~/ti". If I then go to the products page of the CCS preferences it is only looking in "/Applications/ti", if I then add "~/ti" it still does not find MSPWare. I have also tried adding the MSPWare folder to the search path, "~/ti/msp430ware_3_80_03_07" but MSPWare is still not found when I hit the "Rediscover..." button.

What am I missing here?

  • Hello,
    Do you see a little green "down" arrow next to the MSPWare package in Resource Explorer now? Are you able to import examples from MSPWare into CCS desktop? If so, then it looks like it was downloaded successfully and recognized by CCS.

  • H Ki,

    Yes, I can verify that MSPware is successfully downloaded to "~/ti" and that I can import the examples to CCS from the Resource Explorer. However I cannot get MSPware to show up in "Preferences->CCS->Products". This means that I can't use MSPWare in a project.



  • I don't believe MSPWare will show up in the "Products" list. I don't see it in mine either. But it doesn't mean it is not installed. If you can import/build/run the examples from Resource Explorer, then you are certainly using MSPWare. What issue are you running into when trying to use it?



  • Hello,
    I haven’t heard back from you, I’m assuming you were able to resolve your issue. If not, please post a reply with an update below (or create a new thread).

  • Hi Ki,

    I was able to get it working by manually adding the proper folders to my project's include paths. I think I remember on an older version that this was done automatically just by adding mspware as a product but maybe I'm mistaken. Thanks for your help.