This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Managed Make Project File Error

Other Parts Discussed in Thread: LM3S8962, LM3S8938, LM3S3748

Normal 0 21 false false false MicrosoftInternetExplorer4

Good morning,


I need your help in the following case please:

It is my first project with µC

I’m using your software CSS4. I have no evaluation Kit as Stellaris

® LM3S8962 Ethernet and CAN Evaluation Kit  

I’ve installed the software (StellarisWare® Package) .

From step 4(in the QUICKSTART – CODE

COMPOSER STUDIO™ document) and further I receive a “Managed Make Project File Error” which says

“The Managed Make project file could not be read because of the following error:


Error loading Make project information for project driverlib. The tool definition used to create are not available.

Managed Make functionality will not be available for this project.”


What is this tool (red in the massage)?

Can I virtually simulate (without evaluation Kit) the LM3S8938?

Normal 0 21 false false false MicrosoftInternetExplorer4

Best regards

Bassel Daou

  • What is the specific version of CCS4 you are using? It has to be v4.1.0 or higher to work with Stellaris. The error sounds like your version of CCS does not have the correct tool definitions (in other words, the proper support required) for the project you are trying to open. Please make sure to have a clean install of CCS 4.1.0 or higher. CCS can be downloaded from

    Bassel Daou said:
    Can I virtually simulate (without evaluation Kit) the LM3S8938?

    CCS does not have simulators for Stellaris parts, you would need a evaluation kit to debug.

  • I know this problem is already answered and verified, but I found another problem and solution to the same error.  Figured it could be added here for anyone else that may search for the same Managed Make error.  The problem for me was the version of StellarisWare.  I have an EKS-LM3S3748 evaluation board and CCSv4.2.1.00004.  I downloaded the latest version of StellarisWare which at this time was SW-EK-LM3S3748-8049.  Using this version produced the Managed Make error whenever I imported or opened a project.  To fix this I downloaded the entire LM3S3748 CD image which contained the StellarisWare version SW-EK-LM3S3748-7243.  This version of StelarisWare worked perfect.

    One difference I noticed between the two versions was the project files for driverlib.  The SW-8049 version had two project files -- driverlib-cms4 and driverlib-cms.  these projects caused the error.  The SW-7243 version had one project file -- driverlib.  This project worked fine.


    Hope this helps!