This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Compiler/MSP430F5259: "Reviving" an old TI-RTOS/CCS v6 project

Part Number: MSP430F5259
Other Parts Discussed in Thread: MSPWARE

Tool/software: TI C/C++ Compiler

Hello, 

I'm trying to restore a very old project - MSP430F5259, TI-RTOS based, built circa 2015/6.

I've installed the latest TI-RTOS(2.20) / MSPWare (3.80.03.07) /CCS (v901) / xdctools (3.55.02.22) and pulled the source and project files from git.

I just can't get it to build properly.

I'm afraid that I'm experiencing a mess-up between older and current versions of the dev tools/libraries etc and probably system 'macros' (aka 'variables' such as ${COM_TI_MCU_MSP430WARE_LIBRARY_PATH}) are probably irrelevant...

Is there a way / clear guide of how to prepare a clean build environment comprising the ide (ccs), rtos, xdctools and supporting MSPware libraries (or are these part of the RTOS distribution) + sys 'variables', and what are their interdependencies - e.g. which versions work with which, is there a forward compatibility, driverlib & iqmathlib location (MSPware folders or TI RTOS folders) etc etc..

What is the correct way to recover an old project as I'm spending hours and hours to no avail  :-(

Thanks

  • We don't have a specific guide as such, but if you can provide more details about the build errors we could try to steer you in the right direction. 

    Do you happen to know which version of MSPWare was used for the original project?

    I will say that TI-RTOS and XDCtools need to be compatible for things to work right. For TI-RTOS v2.20.00.06, the release notes mention dependency of XDCTools 3.32.00.06 or higher and MSP430 compiler version 15.12.1.LTS or later. I would recommend setting your project to first build with XDCTools 3.32.00.06 and MSP430 compiler 15.12.1.LTS and get that working.

    You can download and install XDCtools from http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/index.html

    For the specific compiler, you can install it into CCS using the procedure described in this page: 
    http://software-dl.ti.com/ccs/esd/documents/ccs_compiler-installation-selection.html

    Then select these versions in the project's properties and rebuild the project. If errors are generated, please save the complete build log to a text file and attach it here for us to take a look.

  • Hi, 

    I'm trying to build a (2016) working environment from scratch:

    Downloaded and installed CCSv6.2

    Downloaded xdctools_3_32_00_06_core 

    Downloaded tirtos_msp43x_2_20_00_06 

    Now I try to build tirtos drivers for MSP430F5259- I follow this post  on porting ti rtos with some minor modification:

    • Updated dev list :
      "MSP430DEVLIST := MSP430F5259"

    • Updated build tools version to the version that comes with CCS v6.2:
      ti.targets.msp430.elf.MSP430X ?= $(TI_INSTALL_DIR)/ti-cgt-msp430_15.12.7.LTS
      ti.targets.arm.elf.M4F ?= $(TI_INSTALL_DIR)/ti-cgt-arm_15.12.7.LTS

    • Disabled MSP432 builds:
      "MSP432_BUILD ?= false"

    Per the post, I've tried to build using the 'build-ccs-msp430-driverlib' flag (..\xdctools_3_32_00_06\gmake.exe -f tirtos.mak build-ccs-msp430-driverlib) to no avail,

    c:\ti\tirtos_msp43x_2_20_00_06>..\xdctools_3_32_00_06_core\gmake.exe -f tirtos.mak build-ccs-msp430-driverlib
    gmake[1]: Entering directory `c:/ti/tirtos_msp43x_2_20_00_06/products/msp430_driverlib_2_70_01_01a'
    gmake[2]: Entering directory `c:/ti/tirtos_msp43x_2_20_00_06/products/msp430_driverlib_2_70_01_01a/driverlib'
    "Building for MSP430F5259 for the MSP430F5xx_6xx Family"
    gmake[3]: Entering directory `c:/ti/tirtos_msp43x_2_20_00_06/products/msp430_driverlib_2_70_01_01a/driverlib'
    "making library directory"
    A subdirectory or file MSP430F5xx_6xx/ccs/MSP430F5xx_6xx already exists.
    gmake[3]: *** [mklib] Error 1
    gmake[3]: Leaving directory `c:/ti/tirtos_msp43x_2_20_00_06/products/msp430_driverlib_2_70_01_01a/driverlib'
    gmake[2]: *** [MSP430F5259] Error 2
    gmake[2]: Leaving directory `c:/ti/tirtos_msp43x_2_20_00_06/products/msp430_driverlib_2_70_01_01a/driverlib'
    gmake[1]: *** [all] Error 2
    gmake[1]: Leaving directory `c:/ti/tirtos_msp43x_2_20_00_06/products/msp430_driverlib_2_70_01_01a'
    gmake: *** [build-ccs-msp430-driverlib] Error 2
    
    

    same when running with 'drivers' flag (..\xdctools_3_32_00_06\gmake.exe -f tirtos.mak crivers)

    c:\ti\tirtos_msp43x_2_20_00_06>..\xdctools_3_32_00_06_core\gmake.exe -f tirtos.mak drivers
    building tirtos drivers...
    gmake[1]: Entering directory `c:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08'
    building drivers packages ...
    making all: Sat Aug 24 14:04:35 JDT 2019 ...
    ======== .interfaces [./packages/ti/boards] ========
    ======== .interfaces [./packages/ti/drivers] ========
    ======== .interfaces [./packages/ti/drivers/ports] ========
    ======== .interfaces [./packages/ti/mw] ========
    ======== .interfaces [./packages/ti/mw/fatfs] ========
    ======== .interfaces [./packages/ti/mw/wifi/cc3x00] ========
    making package.mak (because of package.bld) ...
    making package.mak (because of package.bld) ...
    making package.mak (because of package.bld) ...
    making package.mak (because of package.bld) ...
    making package.mak (because of package.bld) ...
    making package.mak (because of package.bld) ...
    js: "C:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08/drivers.bld", line 126: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: C:\ti\tirtos_msp43x_2_20_00_06\products\bios_6_46_00_23\packages\ti\targets\msp430\elf\package.xdc found along the package path, but no schema file was found.  Ensure that the package 'ti.targets.msp430.elf' is completely built.
    js: "C:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08/drivers.bld", line 126: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: C:\ti\tirtos_msp43x_2_20_00_06\products\bios_6_46_00_23\packages\ti\targets\msp430\elf\package.xdc found along the package path, but no schema file was found.  Ensure that the package 'ti.targets.msp430.elf' is completely built.
    js: "C:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08/drivers.bld", line 126: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: C:\ti\tirtos_msp43x_2_20_00_06\products\bios_6_46_00_23\packages\ti\targets\msp430\elf\package.xdc found along the package path, but no schema file was found.  Ensure that the package 'ti.targets.msp430.elf' is completely built.
    js: "C:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08/drivers.bld", line 126: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: C:\ti\tirtos_msp43x_2_20_00_06\products\bios_6_46_00_23\packages\ti\targets\msp430\elf\package.xdc found along the package path, but no schema file was found.  Ensure that the package 'ti.targets.msp430.elf' is completely built.
    gmake[1]: *** No rule to make target `package.mak', needed by `.interfaces'.  Stop.
    js: "C:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08/drivers.bld", line 126: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: C:\ti\tirtos_msp43x_2_20_00_06\products\bios_6_46_00_23\packages\ti\targets\msp430\elf\package.xdc found along the package path, but no schema file was found.  Ensure that the package 'ti.targets.msp430.elf' is completely built.
    js: "C:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08/drivers.bld", line 126: xdc.services.global.XDCException: xdc.PACKAGE_NOT_FOUND: C:\ti\tirtos_msp43x_2_20_00_06\products\bios_6_46_00_23\packages\ti\targets\msp430\elf\package.xdc fougmake[1]: *** nd along the package path, but no schema file was found.  Ensure that the package 'ti.targets.msp430.elf' is completely built.
    No rule to make target `package.mak', needed by `.interfaces'.  Stop.
    gmake[1]: *** No rule to make target `package.mak', needed by `.interfaces'.  Stop.
    xdctools_3_32_00_06_core\gmake.exe: *** [packages/ti/boards,.interfaces] Error 2
    xdctools_3_32_00_06_core\gmake.exe: *** Waiting for unfinished jobs....
    gmake[1]: *** No rule to make target `package.mak', needed by `.interfaces'.  Stop.
    gmake[1]: *** No rule to make target `package.mak', needed by `.interfaces'.  Stop.
    xdctools_3_32_00_06_core\gmake.exe: *** [packages/ti/mw,.interfaces] Error 2
    gmake[1]: *** No rule to make target `package.mak', needed by `.interfaces'.  Stop.
    xdctools_3_32_00_06_core\gmake.exe: *** [packages/ti/mw/fatfs,.interfaces] Error 2
    xdctools_3_32_00_06_core\gmake.exe: *** [packages/ti/drivers/ports,.interfaces] Error 2
    xdctools_3_32_00_06_core\gmake.exe: *** [packages/ti/drivers,.interfaces] Error 2
    xdctools_3_32_00_06_core\gmake.exe: *** [packages/ti/mw/wifi/cc3x00,.interfaces] Error 2
    gmake[1]: *** [all] Error 2
    gmake[1]: Leaving directory `c:/ti/tirtos_msp43x_2_20_00_06/products/tidrivers_msp43x_2_20_00_08'
    gmake: *** [drivers] Error 2
    
    c:\ti\tirtos_msp43x_2_20_00_06>

    I tried to clean and rebuild, still no success (..\xdctools_3_32_00_06\gmake.exe -f tirtos.mak clean)

    So, 

    What should be the first step in setting up an operational environment?

    Thanks

  • Hello,

    Please see below page for more details.

    http://www.ti.com/tool/TI-RTOS-MCU

    Click “Get Software” button above and download the TI-RTOS. See release notes for compatible tools versions.