This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TINA/Spice/OPA350: ngspice complaines about TEMP variable

Prodigy 195 points

Replies: 2

Views: 67

Part Number: OPA350

Tool/software: TINA-TI or Spice Models

Hello,

I am completely new to modeling and certain reasons I have to use ngspice as modeling software. I have downloaded PSPICE model of OPA350 and I have made the expected modification on the LIB file but there is still a TEMP variable in the line 237 which makes error message: "undefined number". Could anyone help me how to modify the model to work?

  • Lazlo,

    TEMP is a global parameter in Pspice and can be used in throughout a model and simulation.
    It sounds like this isn't the case in ngspice.

    I am unfamiliar with ngspice, but as a workaround, you might try entering TEMP as a local parameter.
    Open the file OPA350.lib with a text viewer, or with the ngspice model editor if it has one.
    In the subcircuit where the TEMP variable is used, enter the statement .PARAM TEMP = 27.
    My editor shows this subcircuit starts on line 227.

    It will look like this:

    .SUBCKT VOS_DRIFT VOS+ VOS-

    .PARAM DC = -9.57E-05

    .PARAM POL = 1

    .PARAM DRIFT = 4.00E-06
    .PARAM TEMP = 27
    ...

    Please give this a try and let me know if it works.

    Regards,
    John
    Regards,
    John

     

     



  • In reply to John Miller - WEBENCH Design Center:

    Hi John,

    it works fine, Thank you!

    Laszlo

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.