TIDA-00162: Unable to run the demo app (4CH VIP Capture + Surround View (DSP) + Display (HDMI) (TDA3x only)) with TIDA3xEVM

Prodigy 130 points

Replies: 25

Views: 214

Part Number: TIDA-00162

I have TDA3xEVM with Multides surround view board from Spectrum Digital (http://www.spectrumdigital.com/multides-surround-view-kit/

[IPU1-0]     15.602269 s:  I2C1: DEV 0x3b: RD 0x300a ... ERROR !!!

[IPU1-0]     15.602360 s: src/bsp_deviceI2c.c @ Line 836:

[IPU1-0]     15.602421 s:  I2C1: Error timeout 639 ms!!!

I have attached the full log for your review.

I am not 100% sure about my header setting on the Multides board, so I attached its photo, too.

I would appreciate any suggestions.

Thanks.

DemoAppLog.20201110.txt

25 Replies

  • Hi,

    I'm on vacation & I will get back to you on Thursday.

    Thanks

    Gaviraju

  • In reply to Gaviraju Doddabettahalli Bettegowda:

    Hi,

    Seems the Hw setup is not proper. have you followed the instruction mentioned in the TDA3x user-guide?

    User-guide file: vision_sdk/docs/UserGuides/VisionSDK_UserGuide_TDA3xx.pdf

    Thanks

    Gaviraju

  • In reply to Gaviraju Doddabettahalli Bettegowda:

    It's very confusing since there are some conflicting information from different documents.

    > Refer the TDA2x user guide “VisionSDK_UserGuide_TDA2xx.pdf” for the LVDS set-up.

    Is this the section 2.3.2.1 "DeSerializer board". It says Cam 1 through 4 should be used, but another doc says Cam 1, 2 and 4, 5. Which is correct?

    > Please refer to the “Running VPS Application on TDA3XX EVM” section of the VPS user guide to get the more details

    Can you give me the pointer of this "VPS user guide", please? Where can I find it?

    > The CN2, CN3 and CN4 jumper settings should be set.

    Did you kindly review the photo of my jumper setting in the original post? Is that correct?

    > In case of Multi-deserializer capture through VIP or ISS capture from sensors, board modification is required in the base board to avoid I2C issues

    I assume I can find this information in "VPS user guide".

    Thanks.

  • In reply to Akira Osamoto2:

    Hi,

    • Refer the section 2.3.2.1 for LVDS set-up & can I know which document says Cam 1, 2 and 4, is correct?
    • Refer to the file: ti_components/drivers/pdk_xx_xx_xx_xx/docs/userguide/html/PDK_TDA_VPS_User_Guide.html#Running_VPS_Application_on_TDA3XX_EVM to know the board modification &  CN2, CN3, and CN4 jumper settings
    • We are not able to see the image attached in the previous post, so you can cross verify the settings provided VPS user-guide

    Thanks

    Gaviraju

  • In reply to Gaviraju Doddabettahalli Bettegowda:

    Thank you for the guidance.

    > can I know which document says Cam 1, 2 and 4, is correct?

    TIDA-00162  www.ti.com/.../tidu336 --- Section 2.c says the Cam 1, 2, 5 and 6.

     VisionSDK_UserGuide_TDA2xx.pdf  ---  Section 2.3.2.1 says Cam 1, 2, 3 and 4

    > Refer to the file: ti_components/drivers/pdk_xx_xx_xx_xx/docs/userguide/html/PDK_TDA_VPS_User_Guide.html#Running_VPS_Application_on_TDA3XX_EVM to know the board modification &  CN2, CN3, and CN4 jumper settings

    For the board modification, please confirm that the followings are what you are referring to, and they are required for my configuration (TDA3xEVM with Multides surround view board from Spectrum Digital (http://www.spectrumdigital.com/multides-surround-view-kit/)

    I need the firm confirmation so that I can request such physical modifications to the team.

    ER15: ADJUST THE I2C PULLUPS TO PULLUPS TO IMPROVE OPERATION WITH
    FROM 101370-2202R TO 101370-1003R, 2.2K TO 10K
    SHEET 8, R9315, R9316
    SHEET 9, R9371, R9372, R9373, R9374
    SHEET 28, R9391, R9392, R9394, R9395
    SHEET 29, R9397, R9398
    SHEET 30, R1058, R1059

    > We are not to see the image attached in the previous post, so you can cross verify the settings provided VPS user-guide

    I attached the image here. Please kindly review.

  • In reply to Akira Osamoto2:

    Hi,

    I will check the team & let you know.

    Thanks

    Gaviraju

  • In reply to Gaviraju Doddabettahalli Bettegowda:

    Can you give me an update, please?

    Regards,
     Akira

  • In reply to Akira Osamoto2:

    Hi,

    Just follow the mentioned use-guide in the above post & connect the camera modules to 1,2,5 and 6.

    Refer the following document to know more about SRV use-case

    file: vision_sdk/docs/SurroundView/VisionSDK_Overview_SurroundView_Demo.pdf

    file: vision_sdk/docs/SurroundView/VisionSDK_UserGuide_2D_SurroundView_Demo.pdf

    file: vision_sdk/docs/SurroundView/VisionSDK_UserGuide_3D_SurroundView_TDA3xx_Demo.pdf

    file: vision_sdk/docs/SurroundView/VisionSDK_UserGuide_2MP_3D_SurroundView.pdf

    file: vision_sdk/docs/SurroundView/VisionSDK_UserGuide_3D_SurroundView_Manual_CalibTool.pdf

    file: vision_sdk/docs/SurroundView/VisionSDK_UserGuide_SurroundView_Calibration_TDA2xx.pdf

    Note: If the camera connection 12 5 6 is not working then try to switch it 1 2 3 4 & it's independent of the base-board physical modification.

    Thanks

    Gaviraju

  • In reply to Gaviraju Doddabettahalli Bettegowda:

    Hi,

    Thank you for the pointers to the documents, but they are not answering my original questions.

    * I believe I followed every steps in the user guide for the hardware setup, but I am getting the I2C error as I attached in the original post. What do you think how can I solve the issue?

    * It is not clear if I need to have the physical board modifications. Please confirm.

    * Is the header configuration I have attached in the previous post correct?

    Regards,
     Akira

  • In reply to Akira Osamoto2:

    Hi,

    > * I believe I followed every steps in the user guide for the hardware setup, but I am getting the I2C error as I attached in the original post. What do you think how can I solve the issue?

    > * It is not clear if I need to have the physical board modifications. Please confirm.

    > * Is the header configuration I have attached in the previous post correct?

    I have tried the followings, but the situation doesn't change. I'm still getting the I2C errors.

    * Tried both CH 1,2,5,6 and CH 1,2,3,4

    * Set the I2C frequency to 100K as shown in PDK TDA VPS user guide and rebuilt the app

    Error messages are:

    [IPU1-0] 32.505429 s: CHAINS: ChainsCommon_MultiCam_StartCaptureDevice
    [IPU1-0] 32.505734 s:
    [IPU1-0] 32.506039 s: i2cMdSubmitChan: i2c0 transfer to slave address 0x23 failed
    [IPU1-0] 32.506130 s: src/bsp_deviceI2c.c @ Line 667:
    [IPU1-0] 32.506222 s: I2C0: DEV 0x23: ERROR !!!
    [IPU1-0] 32.506313 s: src/bsp_deviceI2c.c @ Line 689:
    [IPU1-0] 32.506374 s: I2C0: Error timeout 0 ms!!!
    [IPU1-0] 32.506466 s: src/bsp_boardTda3xx.c @ Line 1961:
    [IPU1-0] 32.506527 s: I2C read failed!!
    [IPU1-0] 32.506588 s: src/bsp_board.c @ Line 620:
    [IPU1-0] 32.506649 s: Device select failed!!
    [IPU1-0] 32.506710 s: VIDEO_SENSOR: Device select failed !!!
    [IPU1-0] 32.507533 s: VIDEO_SENSOR: INST1 : I2C1 : I2C Addr = 0x38