• TI Thinks Resolved

WEBENCH® Tools/LM63615-Q1: Simulation problems with Switching Buck Converter in PSpice for TI

Prodigy 70 points

Replies: 4

Views: 36

Part Number: LM63615-Q1

Tool/software: WEBENCH® Design Tools

I tried to enter our schematic using the LM63615-Q1 into PSpice for TI, but had problems with specifying the input source for analysis.  I finally downloaded the reference designs through the TI website link and those worked well.  This is a complex part (internally) and the simulation takes a while.  I need some help figuring out several issues.

  1. Type of source to use for simulation runs.
  2. Simulation setup parameters for detailed or not-so-detailed (faster) runs.
  3. How to set up and change mode variables for start-up or steady-state simulations.

Any suggestions are appreciated.

  • Hello James,

    Do you have your simulation files to share?

    Perhaps we can take a look at the settings.

    Cheers,
    Denislav

  • In reply to Denislav Petkov:

    Denislav,

    I will attach a compressed folder.  Thanks for asking.

    Keep in mind that I am new to PSpice for TI and the library files in question were created by me from manuafacturer PSpice model or subcircuit text files.

    Jamesveethree emc filter-2020-11-20T14-29.zip

  • In reply to Denislav Petkov:

    Denislav,

    This problem happened repeatedly last week. Now on Monday 23 Nov 2020 after first booting up my computer ... the problem doesn't happen and the AC simulaton runs fine. I think I'll make some changes to this filter, such as run the source from the opposite end to check for conducted emissions at the input. Maybe it will give me the .LIB error again (?).

    Thanks for considering my question.

    James

  • In reply to James Goss:

    Hello James,

    It sounds like you managed to get the simulation running which is good news! Is this correct?

    If you are having problems with the simulation run time in the future, I'd recommend enabling Auto Converge to speed up the simulation time. This will essentially loosen up simulation tolerances in order to get your simulation to converge.

    Auto Converge can be found under Simulation Settings -> Options -> Auto Converge.

    Regards,

    Harrison Overturf