This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TINA/Spice/OPA2244: Delete/Reinsert Bug

Part Number: OPA2244
Other Parts Discussed in Thread: TINA-TI,

Tool/software: TINA-TI or Spice Models

Hi There - I've got a current multiplier circuit with a OPA2244.  Seems that if I delete the component and add it back in, the simulation produces different results.  I can send my model.

  • Hello Andy,

    Yes, please attach the TINA-TI simulation to your next post. A more detailed description of exactly how to re-create the anomaly would be appreciated as well. Perhaps you could include some screen shots of the expected vs. different results.
  • Hi Pete,

    Simulation attached.  Just run it. Look at results (1st screen capture below).  Make a copy of the OPA2244.  Delete the original.  Move the new OPA2244 into the position of the old one.  Rerun.  Compare results, they are different (2nd screen capture below).  Now, do the same with the 15VDC power supply VS1.  Voilà, back to the same results.  Don't think that was supposed to happen.  What's wrong?

    The whole reason that I was doing is because I wanted to try out different op amps.  I was getting strange results.  Thought it might be the cut and replace messing it up.  So in debugging, I just tried to cut and paste the same item.  Hence, the problem above.  The end game would be to be able to swap in new op amps to examine their performance.  Thanks for your help.




    Might be helpful for my debugging if I could see the spice code.  Is there a way to do that?


  • Hello Andy,

    I have 3 observations:

    1) There is no reference point for in this schematic.  I recommend adding a ground connection somewhere.  

    2) Looks like the supply voltage is 5V, not 15V.

    3) Make sure that when you copy/cut/paste components in the schematic that you drag them around to make sure the pins connect properly to the amplifier.  For example, I dragged the op amp after replacing it and it looks like pin 1 was not properly connected:

    Please let me know if one, all, or some of these observations help solve the issue.

  • Thanks Pete!

    The ground reference fixed the problem.  Can you offer any background on why that has an impact?


  • Hello Andy,

    Glad to hear it worked!

    Our models, just like real devices, need a reference potential to operate correctly. We do not have any internal nodes connected to ground, so essentially the amplifier was 'floating'...hence the weird results.