This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TIDA-00281: Flyback converter circuit isolated 12V output not working (incorrect resistor value was fitted to FB pin)

Part Number: TIDA-00281

Our PCB supplier has manufactured and assembled four boards of the TI reference design TIDA-00281 (Automotive 48V 1kW Motor Drive Reference Design).

Unfortunately, during assembly they mixed up resistor R46 (61.9k) which is used for the flyback converter and R5 (174k) which is used for the high-hide protection controller.

i.e. they fitted R46 as 174k and R5 as 61.9k

Two of the boards were powered up with this resistor mix up which is when I found the flyback converter didn't work.

  • The 5V output (5V_A) was about 2.5V and unstable (LED3 flickered)
  • The 12V ouput (12V_B) was zero (LED4 was off)

It was only after this when I noticed the value of R46 was 174k, so I removed the resistor and fitted it with a 62k (a 61.9k was not available at the time).

After doing this, the 5V output (5V_A) worked the 12V ouput (12V_B) was still zero.

I replaced R46 on the two remaining boards (which had not yet been powered up) with 62k and both the 5V output (5V_A) and 12V output (12V_B) worked.

So it appears that powering up the boards with R46 as 174k (instead of 61.9k) caused something to fail for the 12V output. 

I assumed that the failure was more likely to be with a semiconductor than a resistor, capacitor or the transformer.

I returned the boards to the manufacturer and asked them to replace the semiconductor devices used in the flyback circuit (in addition to correcting the mix up with R46 and R5).

I asked the manufacturer to replace:

  • U8: TPS40210QDGQRQ1
  • Q3: FDD86113LZ
  • D6: MMSD914T1G
  • D7: MURS120-13-F
  • D8: MMSD914T1G

However, changing the semiconductors has made no difference because the 5V output works but the 12V output does not work.

So I swapped the transformer (T1) from a working board to a non-working board, but again this made no difference.

Therefore the failure does not appear to be with the semiconductors or the transformer, leaving only the resistors, capacitors or the PCB itself.

What is likely to have failed ?  How can I diagnose which device has failed ?