This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CC2650: Debug Error: Error connecting to the target: (Error -242 @ 0x0) A router subpath could not be accessed.

Part Number: CC2650
Other Parts Discussed in Thread: UNIFLASH,


I am quite new to CCS, the use of the CC2650, and its Launchpad, so bear with me.

I have been working on some code and have been having success in making improvements and uploading it to the hardware. Recently, however, when trying to upload/debug I get an 'error connecting to the target'. The full description of the error message is below: 

Error connecting to the target:
(Error -242 @ 0x0)
A router subpath could not be accessed.
The board configuration file is probably incorrect.
(Emulation package

I used to get this error message before and was told it was because of a dodgy USB connection. Fiddling around with both the USB and JTAG connection fixed the issue before, but now it doesn't budge. I have tried several different USB cables and way's in which to connect my setup. Still, I get the error.  

I have had a look at the board configuration file, but not sure how to approach the debugging process with it. From the 'test connection' button I receive the same -242 error. 

Does anyone know what the issue might be? I might have missed something very fundamental since I am a beginner. 

Thank you in advance.

  • Hello PR, 

    You are correct that this is typically a USB connection issue.  We typically recommend using the micro USB cable which is packaged with the LaunchPad.  Sometimes the computer can hinder the connection stability as well.  What is your OS and CCS version?  Have you tried Flash Programmer or Uniflash, from where did you get your current LAUNCHXL-CC2650, and do you have other LaunchPads to test with?


  • Hello Ryan,

    Thank you for your response. I will try to look for the micro USB that was packaged with the Launchpad. I was handed only the board itself so have just been using my own micro USB. 

    I am using windows 10, and am using CCS studio 8.2.0. I have not tried the Flash Programmer or Uniflash (not sure what those are but will look into them now). I obtained the LAUNCHXL-CC2650 from my professor, who, to my knowledge, only has one of them. I believe he obtained the Launchpad from TI itself. 

    Is there a way to check whether the configuration file is the one at fault? I have used different micro USB's so that's why. 

    Thank you for your help on this matter.

    Kind Regards,


  • You could try using the same XDCTools and compiler for your project on a newer version of CCS (currently v12.0) or reduce the JTAG speed of the .ccxml through Advanced Options -> Target Configuration -> Texas Instruments XDS110 USB Debug Probe -> JTAG TCLK Frequency.


  • Hello Ryan,

    Thank you for your reply. I tried changing the JTAG TCLK frequency but the same error popped up. The issue ended up being hardware related. The problem is now solved!