This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-CC2650: Am rebuilding my ccsv7 environment and am unable to compile example projects

Part Number: LAUNCHXL-CC2650
Other Parts Discussed in Thread: CC2640

I followed SWRU393E Bluetooth® low energy Software Stack 2.2.x Developer's Guide section 2.6.3 exactly as described to recreate an environment I had four years ago.

I downloaded and installed ccsv7 in default location at C:\ti\ with SimpleLink Wireless MCUs support on my windows 10 pro 22H2 pc.

I downloaded and installed ccsv7 updates.

I downloaded and installed TI ARM Compiler 5.2.4

I downloaded and installed TI BLE SDK V2.2.1 in default location.

I verified the list of ccsv7 installed software.

I imported CCS TI projects: simple_peripheral_cc2650lp_app,simple_peripheral_cc2650lp_stack, spp_ble_server_cc2650lp_app, spp_ble_server_cc2650lp_stack

I get many errors on both app and stack.

Here is an example error: gmake: *** [all] Error 2 on element spp_ble_server_cc2650lp_stack

I updated to TI ARM Compiler 5.2.6, no luck.

I updated to TI ARM Compiler 5.2.9 (latest), no luck.

Did something change in the four years since I created the original environment? Back then, following this procedure, I had no issues compiling projects.  I will post more error messages on request, but the errors are the same on all project apps and stacks.

  • Hi Dennis,

    Thank you for reaching out to us. We will take a look at this and get back to you as soon as possible.

    Best Regards,


  • Hi,

    Check the dependencies at the readme file. My BLE Stack 2.2.7 example programs builds at CCSv9.2. Also, build the stack first then the app.


  • Thank you for your suggestions.  Dependencies check out.

    I tried BLE Stack 2.2.7 example program simple_peripheral_2650lp with CCSv9.3.0 and ARM Compiler 16.9.4.  I always build the stack first and then the app.  I get different build errors with this one.

    gmake: *** [build-1641678497] Error 2 simple_peripheral_cc2650lp_app C/C++ Problem
    gmake: Target 'all' not remade because of errors. simple_peripheral_cc2650lp_app C/C++ Problem
    gmake.exe: *** [package/cfg/app_ble_pem3.xdl] Error 1 simple_peripheral_cc2650lp_app C/C++ Problem
    gmake[1]: *** [build-1641678497-inproc] Error 1 simple_peripheral_cc2650lp_app C/C++ Problem

  • Hi Dennis,

    Is this error from the console or the problems tab? Can you share a screenshot of the problems tab View->Problems. Here is my build.


  • Here is my screenshot for the 9.3 issues

  • Hi Dennis,

    Seems you do not have the required xdctools installed download it from below and install at default c:\ti

    After installation go to CCS Windows->Preferences->Code Composer Studio->Products and then check if the required dependencies are there the tirtos and xdctools if not click refresh. After that build stack then app.


  • Markel,

    Thank you for your advice.

    I notice that xdctools_3_32_00_06 is identified in the error message.  I verified that it is installed in CCSv9.  I uninstalled it.  I deleted it.  I downloaded a fresh copy from ti.  I extracted the folder (by moving the folder) to C:\ti\.  I installed it in CCSv9.  No luck.

    The same errors remain.

    I noticed  xdctools_3.55.02.22 and xdctools_3.55.00.11 - "FOR USE WITH CCS 9.0 (or later) ONLY" at the xdctools download website.  I verified xdctools_3.55.02.22 is already installed.  I noticed that xdctools_3.55.00.11 is installed at C:\ti\ccs901\.  Also found xdctools_3.60_02_34 installed at C:\ti\ccs901\.  I uninstalled both, moved both to C:\ti\ and installed.  This didn’t change anything as expected, but I verified that these xdctools are installed at C:\ti\.

    I verified that xdctools_3_32_00_06, xdctools_3.55.02.22 and xdctools_3.55.00.11 are all located at C:\ti\ and installed in CCSv9.

    I built the stack and then the app.

    The errors remain.  Let me know what else to try.  Thanks!


  • Hi Dennis,

    Downgrade to CCSv8.2. I just installed CCSv8.2 and BLE stack 2.27 simple peripheral example program builds without errors. Make sure the required dependencies are there.

    If your still encountering build errors, try the same at a different PC.


  • No luck with CCSv8.2 and BLE stack 2.2.7. Same errors as in my previous screenshot.  Dependencies are satisfied.  I don’t have another computer to try.  I appreciate your help, but I’m going in circles.

  • Hi Dennis,

    The reason why I asked you try at another PC is to find out if there is something at your current PC that is causing this. I have experienced a similar issue and I would recommend you to delete or uninstall all your CCS folder installations, xdctools, tirtros, workspace folders at c:\ti. If you have important projects at your workspace folders copy those to another folder. Turn off your antivirus then install all again. I am not sure if this will work with your issue.

    I am going to loop in a CCS expert who might be able to help


  • Thanks. I won't be able to try again until April 3.

    Just so you know, all folders and installations are freshly downloaded as there were no ccs, xdctools, tirtos and workspace folders until I started rebuilding my environment.

    I have BLE 2.2.1, 2.2.2 and 2.2.7 installed. I have tried them all with the same 4 errors occured first with ccsv12, then ccsv7.4 and finally ccsv8.2.

    Real time virus scanning is turned off each time I install something.

    I am replicating an environment that worked previously four years ago on this same pc.

  • Hi kel,

    I fired up an old 2007 power pc running the last available version of Windows 7, downloaded and installed cccsv8.2, ble_sdk 2.2, compiler 5.2.6.  The simple_peripheral_cc2650lp_stack _app compile without errors.  The machine runs as slow as a pitch drip, but my task is completed.  My next step is to combine the hex files and transfer them to my custom cc2640 board.

    I suppose I have a personal problem with my Windows 10 configuration.

    This resolved my issue.  Thanks for giving me the confidence to try this.