This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BOOSTXL-CC2650MA: Cant programming a snp file

Part Number: BOOSTXL-CC2650MA
Other Parts Discussed in Thread: CC2650, SIMPLELINK-SDK-BLUETOOTH-PLUGIN

I am working with the MSP432P401R Launchpad and CC2650 Module BoosterPack.

At first I tried the 'project zero' from SIMPLELINK-SDK-BLUETOOTH-PLUGIN_1.40.00.42 It worked ok, I tried it with BLE Scanner and was able to control LEDs and get button press notifications. However, I could not see any reply from the serial terminal. So, I thought it could be because of the SNP image file.

Then I tried the 'sensor_boosterpack' example. But this time it didn't work. The BLE scanner App could not detect any BLE device. I pressed S1, which should start the advertising. But no response.

This time I got a reply from the serial terminal at startup. But there should be a line 'State set to idle!' according to the manual which was missing.

I pressed the S2 button. According to the manual, it should update the SBL. But nothing happened.

Therefore, I decided to download the SNP hex file [simple_np_cc2650bp_uart_pm_sbl_2_02_01_18a_merge.hex] into the CC2650 module.

I followed this guide - SimpleLink MSP432 SDK Bluetooth Plugin User Guide

I connected the XDS110 debugger of the MSP432 Launchpad to CC2650 module boosterpack. Before that, I removed all the J101 jumpers of the MSP432 launchpad. According to the image suggested by the user guide.

Connect the two devices

but I failed to flash the SNP hex file using TI SmartRF Flash Programmer 2

can anyone suggest any solution.

Do I really need to download the SNP, or the sensor_boosterpack example is not working due to some other issues?

If I do need to flash the SNP then how can I overcome the issue regarding the flash programmer failure?

thanks in advance....